Vienna Symphonic Library Forum
Forum Statistics

181,879 users have contributed to 42,190 threads and 254,623 posts.

In the past 24 hours, we have 3 new thread(s), 18 new post(s) and 58 new user(s).

  • VEP 7.2.1481 not opening Logic Pro X projects with recorded audio tracks

    Wonder if anyone else is having this bizarre issue. I’ve been using VEP 7.1.1406 on my macOs Mojave devices until now. After upgrading to 7.2.1481 I was unable to open any of the eight Logic Pro X 10.5.1 projects I am currently working on.

     

    What seems to happen is, when I try to open the project Logic Pro loads all the plugins (which seems to load fine based on the opening progress bar info) but then when it starts loading the audio files (which is what Logic does when opening a project), it freezes and crashes. 

     

    Strangely, my audio tracks are only using plugins which are not even on the VEP7 server; they are all on my local device. So VEP 7 should not be interfering with those tracks. But it is definitely at the last stage of Logic Pro opening where it tries to load up recorded audio files is where Logic Pro just gets stuck and crashes. I was able to create a new Logic project and open it successfully but my existing projects don’t open.

     

    Luckily I had saved the VEP 7.1.1406 installer (no longer available in Vienna Assistant) so I reinstalled that and all my projects opened without any issues! 

     

    Anyone else seeing something like this?

     

    Also, any ideas who to get rid of that “upgrade to 7.2.1481” message every time I open VEP7?


  • Hi, 

    Thanks for reporting. 

    I assume that you are running Logic Pro X 10.5.1 on your system (it's not just the projects that were saved in that version), correct?

    Which OS are you working on there?

    Do you get a crash report and could you please send it to us, with a reference to this thread? support@vsl.co.at

    Of course previous versions are available in Vienna Assistant. Click ROLLBACK on the product pic to see all options, see screenshots. 

    Best, 
    Paul

    Image

    Image


    Paul Kopf Product Manager VSL
  • Hi Paul, thanks for the advice. I am running Logic Pro 10.5.1 and that's also the version I created/saved the projects in. The macOS is Mojave 10.14.6 on both my server (Mac mini 2018 i7) and client (iMac 2015 i7) devices.

    Unfortunately I did not get a crash report when this happened. Logic just hangs, the coloured ball kept spinning and when Logic Pro didn't quit/crash for around d 3-4 minutes, the only way to proceed was to do a Force-Quit and that did not generate a crash report. I also looked in the Console app but couldn't see a crash report for Logic.

    I have since tried the VEP 7.2.1481 update on my 2015 MacBook Pro 2015 i7 which is also running macOS Mojave 10.14.6. This time the project opened but after opening as soon as I move the cursor or try to click on anything in Logic Pro, it would freeze and I get the coloured spinning ball. However after leaving the project open for around 25-30 minutes, I was finally able to use the project! Sadly, when I saved the project and tried to reopen it, it again needed another 25-30 minutes before I could use the project. It seems that after upgrading to VEP 7.2.1481 Logic Pro is doing a very long scan each time I open any of my existing projects.

    I am happy to keep using VEP 7.1.1406 for now but I am concerned that I may get stuck on this older version and may never be able to upgrade to a new version? I also keep getting the upgrade window each time I open VEP7 and I am wondering how I can disable that for now? 


  • Also, forgot to mention, I tried the Rollback option from Vienna Assistant but it doesn't do a correct rollback. It removes the VEP 7.2.1481 plugins (.component, .vst, .vst3 files) but it doesn't install the ones for VEP 7.1.1406. I had to use my previously-saved ".pkg" file for VEP 7.1.1.406 and that managed to reinstall the plugins. Just something that may be useful your other users in case they have this issue.


  • This just happened to me too, rolling back removes all Vienna Ensemble Pro VST3 plugins for me and does not install rolled back versions, I now only show Pro Surround and am unable to load templates with Ensemble Pro because it doesn't exist


  • Hi, Thanks for your feedback, we‘ll definitely clean that rollback bug up. Regarding the Logic hang, please send us a sample of the process when it hangs. 1) When Logic hangs, open Activity Monitor. 2) Select Logic and click „Sample“ in the upper left window. 3) Save the sample and send it to us: support@vsl.co.at Best, Paul

    Paul Kopf Product Manager VSL
  • Paul, thanks for the tip on getting the sample info from Activity Monitor. I will reinstall VEP7 7.2.1481 and generate that when Logic hangs and send it to VSL support.


  • Update: VSL Support have been looking into this but have been unable to produce the issue on there side. Meanwhile I have tried various versions of Logic on two different devices and I am getting the problem with all versions after 1406. And it turns out the issue isn't so much with the audio tracks etc. The issue is being caused at the very moment when the VEP plugin in Logic Pro X tries to connect to any instance in VEP on the server. As a test, in an empty Logic project when I create just one track with the VEP plugin, when I click CONNECT in the plugin Logic hangs.

    VSL Support have advised that I stay on 1406 for now as apparently developers are currently looking into a general connection problem which was apparently introduced with VEP builds after 1406, and it seems that is causing my issue.  They have advised hopefully the update that fixes it should be released soon.


  • Sorry I didn't see your post sooner. I had the same problem in November with VEP 7.1.1427.

    Like you, I am running OS 10.14.6 and Logic 10.5.1. One difference is that I am running Logic and VEP on the same machine, a Mac Pro 6,1. I just sent details to support as a follow up to my original report, which was Case 482711. 

    Thankfully VEP 7.1.1406 still works for me. Glad to help test this for VSL when they have a fix. 

     Carlos


  • Glad I saw this post before I wrote mine out. Just bought a second license and iLok so I could upgrade VEP on my Mac and server computer, and have run into the same issue with Logic hanging. I just uninstalled on both computers and reverted back to the eLicenser version of 7.0.1120 to get my sessions to work (can't spend too much time messing around on anything I don't know won't run properly at the moment). Running OS 10.15.7 on a 2010 Mac Pro and Logic 10.5.1 and Windows 10 on the PC.


  • Hi, 

    Network troubles are all fixed with the latest 7.2.1516, please give it a try. 

    Best, 
    Paul


    Paul Kopf Product Manager VSL
  • Hey Paul,

    Still hanging when I open a session. I've emailed you the activity monitor sample. Let me know if you need any more info.

    Thanks!


  • Hi Paul

    Thanks for letting us know about the 7.2.1.1516 update. I am about to release an album so don't want to update anything on my computers in case things stop working and my album gets delayed. Judging by the post from KeplersConundrum it seems the issue still occurs, though I will give 7.2.1.1516 a try in mid April after my release and give an update here.

    Regards
    Sal


  • Hi Paul

    Sorry for late update but was busy with album release. I just updated to 7.2.1.516 and unfortunately the problem is still there. Logic just freezes when you try to connect to a VEP instance. I tried with existing Logic projects and also with totally new empty project with one VEP7 plugin on a single track and the both cause the problem as soon as I click the CONNECT button in the VEP7 AU plugin. When I roll back to 7.1.1.406 the problem goes away.

    Best
    Sal


  • This is exactly how I experienced it on my MacPro 6.1 , Mojave 10.14, Logic 10.5.1 and Vepro 1516. After updating to Monterey MacOS 12 and Logic 10.7.6 everything is now fine.


  • Thanks Klavaus - glad its working for someone. Unfortunately upgrading to macOS 12 Monterey is not an option for me because my iMac 2015 can only go upto macOS 11 Big Sur, and I can't even go to that as some of my plugins will stop working.


  • BenB Ben moved this topic from Vienna Instruments Pro on