Vienna Symphonic Library Forum
Forum Statistics

184,842 users have contributed to 42,370 threads and 255,389 posts.

In the past 24 hours, we have 0 new thread(s), 8 new post(s) and 62 new user(s).

  • Errors occurred while loading plugins: AU: Toontrack| EZdrummer (Could not create plugin)

    I updated to latest EZ drummer and now cannot get VE pro to load previously created files. I get the following message:Errors occurred while loading plugins:

     

    AU: Toontrack| EZdrummer (Could not create plugin)

     

    Advice?


  • Hi toodamnhip, 

    Does it work when you roll back to the previous version of EZ Drummer?

    What do my colleagues at Toontrack say to this? Which OS are you working on, which version of VE PRO?

    Best, 
    Paul


    Paul Kopf Product Manager VSL
  • I havent tried anything except un installs and re installs, repair permissions,.If i dont get support by tomorrow, my thought is to manually trash EZ drummer and do an install again, i.e. a deeper cleaning such as prefs and caches before re install, not just using thie "uninstaller", which doesn;t go deep.

    Here is my note to them:

    I was running fine in the latest version of VE Pro and Digital Performer 9.02.
    I have Superior drummer and EX drummer 2.
    This afternoon I updated EZ drummer to the latest update as well as updated several files the new Product manager told me were needing updates. I have kept up with updates before today, but this was the 1st time Id used product manager.
    When I was done, EVERY SESSION FILE in VE Pro gave the message "AU: Toontrack| EZdrummer (Could not create plugin)”

    This sucks because I have a 50,000 project that is now broken.
    I am running DP 9.02 with VE Pro in MAS mode. One a Mac in OS 10.5.5
    Again, all had worked well before.
    Repairs I have tried have been:
    reinstall EZ drummer 2
    repair permissions
    Temporarily Change to AU mode in DP 9.
    Uninstall and re install.

    I did notice that when I uninstalled, upon re installing, the installer called it an “update” and did not give me a choice of where to put the library. This leads me to believe prefs and caches need to be thrown out to effect a full un install.
    But before I go tearing my whole system apart, I would like some tech support instruction or any user that can help.
    It was all working 100% fine before. I did see some sort of warning about VST when I installed the stand alone player, (which I dont need), and I am wondering if that screwed things up.
    Also, if something changed in the latest update of EZ drummer that makes compatibility break with VE Pro, I would like a link to the previous version of EX drummer.

    I am in a tough spot hear and would appreciate any help.

    Dave

     

  • Hi toodamnhip,

    I am afraid I have to confirm the fact that the update from EZDrummer 2.1.1 to 2.1.2 via the Toontrack Product Manager seems to break backward compatibility in VE Pro - one can create new EZDrummer channels, but opening older projects indeed throw the message you have mentioned here as well.

    Unfortunately, I haven´t been able to revert back to 2.1.1 either, so I have no solution for you at the moment - please keep us posted as soon as our colleagues from Toontrack have sent us their reply!

    My apologies for not having better news.

    Best, Marnix


  • I have not heard back. I have all my installers in a fiolder, even beta installers....

    So I have 2.1.1. But I am not sure if I can just install it bakcwards though.

    Thoughts?


  • I had the 2.1.1 Installer available as well, but could not roll back unless I first ran the Uninstaller. Unfortunately, this forced me to re-download the basic Installer, which actually did not install the AU or VST plug-ins - therefore I could not update them to 2.1.1

    So I ran the 2.1.2 Updater again, which miraculously also installed the component (the 2.1.1 Updater did not...), but this did not change anything to the backward compatibility issue...

    Hopefully Toontrack will have a solution to this problem!

    Best, Marnix


  • Belwo you will find my coorespondence with EZ drummer, please comment if you have ideas..

    Dave

    v


  • last edited
    last edited

    Here is my coorespondance with EZ drummer and attempted fixes. Please comment if you all have any ideas.

    Toontrack Support (Toontrack)

    Jul 12, 9:33 AM CDT

    Hi David,

    Thanks for your e-mail,

    In this instance we would first ask you to try and delete the AU cache and see if that helps

    Please quit your DAW and then delete the following file

    /Users/yourname/Library/Caches//AudioUnitCache/com.apple.audiounits.cache

    Best Regards

    Toontrack Music

    www.toontrack.com

    Make sure to download and install the all new Toontrack product manager found here: http://www.toontrack.com/product-manager/

    Actions taken-

    1) deleted- com.apple.audiounits.cache

    (it was not exactly where you said it would be. The instructions said it was inside “AudioUnitCache”, it was sitting in the Main cache folder but not in a sub folder called “AudioUnitCache”.

    2) I re-download and re-installed the Toontrack product manage, just in case there has been an overnight update.

    3) Product manager showed all is up to date.

    4) I opened DP 9.02. It opened normally , without any sort of additonal scanning. Are you sure you didn;t want me to delete DPs or VE Pros individual AU caches?

    5) I opened VE Pro, again, no new scan of plug ins, it opened right away as normal.

    6) Tried to load VE session file.Got error message-

    Errors occurred while loading plugins:

    AU: Toontrack| EZdrummer (Could not create plugin)

    7) On my own now from this point on

    8) I deleted the 3 Vienna Pro preference files and tried starting all again= VE Pro opened without any new scans. Same error message. I put back the old VE pref files.

    9) I opened VE Pro (64 bit) alone and tried to re scane all plug ins in VE Pro.

    (yesterday I had already tried to rescan just the Toontrack plugs and that didn;t work yesterday). Ve scanned all plugs, including EX drummer, with no error messages.

    10) Tried creating a new instance of VE Pro and opneing the saved file without having SP launch the file- got the same error message.

    11) Tried opening and luanching VE Pro-same error message.

    12) Shut off MAS version of VE Pro in DP, created an AU instance in DP, and tried openeing VE Pro only in AU mode. Same error. Since this didn;t work, I restored DP to it’s proper setting, using MAS and no AU.

    13) EZ drummer component = 2.1.2. I try back installing 2.1.1. The 2.1.1 installer said “updater” when it installed. It installed without any warning messages. However, the EZ drummer component still showed 2.1.2 Just in case, I opened DP and luanched VE Pro-same error message=AU: Toontrack| EZdrummer (Could not create plugin

    (I will not that “Pop Rock” keeps showing that I should “install updates”, even though I had done so yesterday. The files no longer load are not Pop Rock by the way).

    14) I opened Product manager to check if the attempt at a back install of 2.1.1 changed anything? It still showed EX drummer as up to date. To be safe, I manually downloaded the EX drummer 2 upgrade from product manager and re installed 2.1.2. It took a long time while runnign it’s “package scripts”, but it installed fine. I opened VE Pro again to check EZ drummer, same error message.

    15) I then tried trashing the two EX drummer prefs. files. No improvement. I put back old pref files to be safe.

    Summary-

    I am out of ideas. This is a 50,000 project and I am losing money daily. Please please provide instructions to totally pull EZ drummer 2.1.2 out of my system and re install 2.1.1. I am not trying to be an ass, but I am not a beta tester for EZ drummer anymore and I cannot lose 50,000 while prgrammers fix this bug. Your update broke my system and I really need it back. I need to go BACK to the old verison of EZ drummer and have my system working again.

    If you wish to attempt more repairs, please provide a real time way to Skype or do something similar because I cannot wait 24 hrs between every attempt to “try another fix”. Tell me, in CALIFORNIA time, what time to be available for real time tech support and I will stay up all night in L.A. if I have to!

    Thank you,

    David.


  • Hello toodamnhip, 

    I might have an unconventional interim solution for you there, please contact me at support@vsl.co.at

    Best, 
    Paul


    Paul Kopf Product Manager VSL
  • Sorry to be a bother, but I have not heard back from Marnix in several days. 

    I have snt the VE Pro session file two times and I am hoping you guys can get it to open and send to me or get me a hot fix?

    Toontrack is off researching the issue and I have no ETA when they will fix. They also cannot get me back to the ealrier versions with their installers.


  • Hi toodamnhip,

    We still haven´t received your session file/VIFrame/Metaframe and it is not attached here either - would you please send it again, perhaps via f.i https://www.wetransfer.com or https://www.hightail.com ?

    Best, Marnix


  • Please let me know you got this-

    Here is a link to my TWO session files: 
     
     
     

  • Hi toodamnhip,

    Unfortunately, none of the two links seem to be working...

    Best, Marnix


  • try adding DOT com. after littlehipster music