Vienna Symphonic Library Forum
Forum Statistics

181,978 users have contributed to 42,198 threads and 254,643 posts.

In the past 24 hours, we have 4 new thread(s), 8 new post(s) and 45 new user(s).

  • VSL-Player waits a long time before it starts (some timeout in the program??)

    Hi there, after I have upgraded from Tiger to Leopard on an Intel-Mac the Vienna Player (does not matter if using Logic plugin or Standalone) seems to have some timeout where he waits for before starting the application ("Vienna-Instruments-Standalone reagiert nicht" is shown in process viewer). This is very annoying because if you load a project in Logic which has many instances of the player, it seems that this timeout has to come up for every instance - which makes it 10 minutes to load a small project. Do we have a bug in the vienna player? Best Regards, Tobias

  • -

  • Hi Tobias, 

    we will need a little bit of information about your system. Which OS exactly, which VI version exactly, which Syncrosoft version?

    How much is "long", how big is a "small project"?

    In general: All licenses are being scanned with the initial startup, which may take between 1 and 2 minutes, depending on the combination of different software versions you are using. The latest versions are always the best. 

    After that first initial startup (you have started your computer, and youÂŽre opening the VIs for the first time), each startup is fast. 

    Thanks for more details in advance!

    BTW: DId you check out the Vienna Ensemble software already?

    Best,

    Paul 


    Paul Kopf Product Manager VSL
  • Hi Paul, I'll try to provide everything... BTW, I could offer you to enable debug-traces (if possible) and send you a log file... OS: MacOS X 10.5 with all patches Syncrosoft: 5.5.24.0 A small project has 12 player instances. The VSL-Server-Process normally needs 1GB RAM if everything is loaded. When "double-click" on the Logic-Project which uses the VSL, the following happens: - Logic initializes. - VSL-Server is started and some time goes by checking the licenses I think. - VSL-Server starts to load data (can be seen in the "task-manager"). - VSL-Server stops to load data, both Logic and VSL "are not responding" for 30-60s. This repeats some times. - After 5-10 Minutes the Logic Project windows opens. I did not check the Ensemble - I thought this program was made If using second machine for Orchestra playback? But there is an additional information. I am loading the samples for Vienna from a firewire-harddrive. And I am using a RME-Fireface 800. This whole "sleeping-and-not-responding-bullshit" does *not* happen in two cases: First case is, I I load samples via USB and not per FireWire, then everything is OK, second case is if I turn off the Fireface... Is there a possibility to find out, what happens? Best Regards, Tobias

  • now thats a really good observation ... so far i've been under the impression the collision between harddisk and audio device on firewire does not happen with RME hardware - some other FW audio devices do not work usefully at all if samples are also streamed via firewire (this seems to be a mac-specific issue).

    what you are basically confirming is that there is a collision between FW audio connection and file access via firewire, in your case in a certain situation, in other cases continuously.

     

    also regarding the increased CPU load during file access via firewire my recommendation is to have the samples preferrably on disks connected via sATA.

    christian


    and remember: only a CRAY can run an endless loop in just three seconds.
  • That sounds a useful information. Is there a chance that RME might help? This did not happen on on "old" iMac with only Firewire 400 and Mac OS X 10.4. Best Regards, Tobias

  • PPC or intel iMac? curious abot details, because this issue is in principle touching nerves (FW audio devices are not so uncommon).

     

    for me there is generally some mystical behaviour on firewire which is probably related to the fact, that asynchronous and isochronous transfer is both possible (and might collide in a driver?)

     

    in case you ask RME and receive some answer shedding more light on the issue please let me know ...

    christian


    and remember: only a CRAY can run an endless loop in just three seconds.
  • (I'd might be a bit out of topic here) Same thing for me, but with an inside serial ATA hard drive for the VSL database (not my OS one of course): the plugin first takes a very long time to check its licenses (between 10 and 20 seconds, when other usb key protected softwares achieve it in a heart beat) then the loading takes a very long time (compare to ESX24 for instance... is the VSL compression involve ? If it's the case, I believe most people don't care about space anymore), but the very disturbing thing is that during the process the cheap VSL loading alert window try to keep the focus ... very very boring and bizarre under OSX : thus you can't even surf the web or type a mail during the long process.

    From a general point of view, and apart from the fact that VSL is a very good product, the OSX/Logic implémentation is very very, very, poor (the fact that you have 2 steps, from your channel strip to that one-button window up to the VSL plugin UI inside Logic, is a good example of what I mean. There's a lot of plugin using their own UI toolkit too, and doing a good job). So I'm sorry to tell that VSL offers by far the worst plugin experience I ever had. Very bizarre knowing that CoreAudio/Au make things so easy to plug into OSX.

    Maybe it could be time for VSL to hire people, or time, from Apple/Logic (just send me a mail if you want me to put you through).

    My music workstation is (still) a PPC 2x2; 4.5GB RAM; VSL Special Edition; OSX Tiger (10.4.11); Logic Pro 7.x and 8.x.

  • please do not compare apples with pears (pun intended!) - i don't know any exs instrument loading almost closely a similar amount of data ...

     

    as posted earlier: in my opinion a professional audio machine should not be used for office tasks like emailing or browsing (or whatever else). this might be only me, but then it doesn't take me wonder why several setups are in the bad shape they obviously are ... now and then or more often ...

     

    also posted earlier: the (vsl-)server solution had to be introduced to overcome (GUI-)performance issues when ViennaInstruments have been released and makes sure you can access a seperate memory space (from the hosting application)

     

    i personally also don't like the design of the loading message (i.e. it opens always on the main monitor even if the VI is on the other one) and would prefer a kind of progress bar, but i'm sure there are reasons for it beeing as is ...

     

    so we are very sorry to hear VSL developers are doing such a poor job with the dead easy CoreAudio/AU architecture and are looking forward you will put us through to more competent people ...

    maybe you can convince them in advance to install even more than the solo strings from their NFRs for some more extensive tests with an application that _really_ needs memory

     

    thx, christian


    and remember: only a CRAY can run an endless loop in just three seconds.
  • last edited
    last edited

    @Another User said:

    maybe you can convince them in advance to install even more than the solo strings from their NFRs for some more extensive tests with an application that _really_ needs memory

    I have no memory issues in my non-professional use of VSL. But loading/license-checking/focus behavior while loading (bug) issues and some desiderata about general UI. (Topic of this thread)

    Thank you to admit you've got some improvement to do here and there (so easily).

    Manuel


  • you're welcome, 

    so i take it you are considering accessing a seperate memory space as no good design ... nevermind.

    please note that video streaming (continuous read) is different from sample streaming (random read) so clearly you will notice a difference in data throughput.

    unfortunately i neither understand the term *real* (vs. unreal) mailbox nor to what you are referring by *fairplay* ...

    IIRC the topic was about vslserver possibly pausing during loading data into different instances if audio and disk is both connected via firewire and not about UI, but feel free to hitchhike the thread ... resp. add your design and programming ideas.

    christian


    and remember: only a CRAY can run an endless loop in just three seconds.
  • By Real I mean out_of_the_forum (I will not post personal information on a forum and I have to get an email address of somebody you might not want to put here either). And by fairplay I mean a serious contact, rather an _open_minded_ R&D_manager_ than the hotline guy (with no offense to him, and great respect to hotline people).

    Manuel

  • Hi Christian, its an Intel-Mac. And I also got an answer from RME: First http://www.rme-audio.de/forum/viewtopic.php?id=1475 Whereby I yet don't really know, what the current state of the problem is, but there is a workaround-description (which I can't evaluate because of missing second FW port at the external Harddrive). Best Regards, Tobias

  • last edited
    last edited

    @topse said:

    ....  Tobias
     

    Hi Tobias

    I'm a bit in a hurry and had not the time to read all other answers.

    Just another point to check out:

    Did you tried to start your system without any Antivirus Program?

    I've G-Data (a German Product)

    I use 5 minutes for starting 1 VI instance (without any Sample) with "G-Data-Guard" 

    I use 40 seconds for starting a VI instance without "G-Data-Guard".

    Best - and good luck

    Beat


    - Tips & Tricks while using Samples of VSL.. see at: https://www.beat-kaufmann.com/vitutorials/ - Tutorial "Mixing an Orchestra": https://www.beat-kaufmann.com/mixing-an-orchestra/
  • last edited
    last edited

    topse, now this is a real bummer ...

    @Another User said:

    there is a new FW 800 chip on the market from Agere, which seems to be incompatible (not only) to RMEs FireWire audio, and requires workarounds for successful operation.

    The reason Apple used this chip instead of the former TI solution is easy to find: half the price and a lot smaller. So it is not astonishing that this chip now also begins to show up on Windows computers. We got our hands on a PCIe FireWire 800 card from Unibrain using this chip, and found the exact (!) same problems under Windows as under Mac OS X using this card.

     

    i know (and have posted this already) that there is really much crap on the market for FW expansion cards, but again it seems apple has given up its credo to use only first class components for their hardware ... now i'm starting to understand why the maxtor oneTouch II works so unreliable on newer macs....

    eg. the (also mentioned) unibrain products are totally useless from my experience and i regulary notice performance issues with VIA chips.

    i've also posted earlier a link to an informative articel about FW incompatibilities http://www.rme-audio.com/english/techinfo/fw800alert.htm

     

    have you checked your iMac is using this chip and i don't understand the *no second firewire port on the harddisk* ... as i've read it they suggest to add an additional FW-controller to the computer (a PCIe34 expansion in the given example, mainly intended for proBooks obviously)

     

    the thread you linked to is also a goldmine for windows (the theysicon links there, a company which really knows what they are doing) although it also states that OS X system information does not provide the correct information about the used chips (if this is true, again a bummer)

     

    some option maybe worth to try comes into my mind (since everything reads like a collison between asynchronous and isichronous mode might be involved) ... try to daisychain your devices the other way around (computer - harddisk - audio vs. computer - audio - harddisk) or given you have a FW controller on the computer with 2 ports connect them both directly (firewire devices work by design like hubs - 1 in, 2 out, 1 for the device), possibly protocol issues can be avoided in one configuration.

     

    heading the NAMM we are a little bit short in time currently but i'll try to organize a double check on our intel Imac (please provide harddisk model to allow a very similar setup)

     

    christian


    and remember: only a CRAY can run an endless loop in just three seconds.
  • last edited
    last edited

    @manu_28410 said:

    And by fairplay I mean a serious contact, rather an _open_minded_ R&D_manager_ than the hotline guy

    well, you are pretty new to VSL, so here are some news: there is no hotline and therefore also no hotline guy who could feel offended or disrespected now ... 😛

    i dare to insist the VSL support team is the most dedicated you might find and closely in contact with the developers and the developers theirselves are true wizards beeing well in touch with almost everybody thinkable on this globe.

    though clearly in a little company like VSL there is always a lack of ressources and a too large wishlist - feel free to contact support@vsl.co.at anytime you think a real issue needs to be solved.

    christian


    and remember: only a CRAY can run an endless loop in just three seconds.
  • Hi beat, thanks for the advice. I yet don't use an Antivir - I hope no one reads this ;-) Best Regards, Tobias

  • Hi Christian, The Harddrive is placed in a Pleiades Firewire400 & USB2-GehĂ€use. The Harddisk itself is 250GB SAMSUNG SP2514N. The HD is connected to the Firewire400-Port, the Fireface800 is using the Firewire800-Port. How exactly can I check which chip my Mac uses? I think, all the experiences are pointing to the bad one... Today I have contacted my hardware vendor. I asked him to solve the problem or take back the computer. I yet don't have an answer but I will keep you updated. Dependent on what he says I will try to buy a Firewire-Hub and test this. Yesterday I tried to use the Pleiades as a hub - but that gave me a kernel-panic (with data-loss ;-( ). Best Regards, Tobias

  • last edited
    last edited

    doesn't the system info tell us something about FW?

    adding a device as FW-hub would assumably worsen the situation - but using the pleiades as hub receiving a kernel panic is scary ...

    pleiades is using assumably oxford chips ... very common and usually reliable, probably an OXUF934DSa

    thx for the details, christian


    and remember: only a CRAY can run an endless loop in just three seconds.
  • The System-Profiler only tells that there *is* Firewire 800 available... but nothing more. Best Regards, Tobias