Vienna Symphonic Library Forum
Forum Statistics

184,839 users have contributed to 42,370 threads and 255,389 posts.

In the past 24 hours, we have 0 new thread(s), 10 new post(s) and 63 new user(s).

  • Yes Logic 10.7.5 has broken the VEP AU3 Plugin ?

    I am finding that my AU3 template won't work at all in Logic 10.7.5, confirmed with a few tests, the VEP works fine, the AU3 version doesn't even seem to receive any midi from Logic. Anyone else seeing this ?

    OS X 12.6.1 on a 2019 Mac Pro 16 core

    Regards

    Dave Hage


  • I also see this from Logic, which is new ?

    Image


  • last edited
    last edited

  • I haven't had that warning popup you showed, nor have I yet had a crash, but I am getting the old problem of VEP client plugins not seeing VEPro addresses, among other misbehaviours.

    I've started rolling back VEP versions to see if I can find one that works with this Logic, and I've also just updated macOS from 12.6 to 12.6.1. My testing is ongoing but thus far it's really not looking good.

    [2017 64GB 7700K iMac, my boot volume is an external Samsung X5 SSD (all S.M.A.R.T. Health indicators showing 100%), and my iLok3 key is on a Sabrent powered USB 3.0 hub (no known problems thus far].


  • last edited
    last edited

    @dfhage said:

    I am finding that my AU3 template won't work at all in Logic 10.7.5, confirmed with a few tests, the VEP works fine, the AU3 version doesn't even seem to receive any midi from Logic. Anyone else seeing this ?

    Yea I think maybe it has.  I'm not getting some of my projects to play back now.  results are garbled audio at best, leading shortly to freeze or crash of logicPro.

    However, keep in mind that this might be a case where Apple broke the project file backwards compatibility.  This would not be the first time they did that.  So opening older projects in LogicPro 10.7.5 might not always interpret them exactly correctly.  There is another reported bug I saw on LogicPro forum along those lines also, and I've seen this kind of thing in the past.  

    Try to create a brand new LogicPro project from scratch with a a few dozen tracks feeding to VePro. AU3 and see if it works.  If that works, then it means LogicPro is confused about opening the older project files...  On the other hand if it also doesn't work to build it up from scratch, then more likely the actual VePro.AU3 plugin is no longer compatible with LogicPro 10.7.5 until it gets some update...or perhaps LogicPro broke AU3 mechanisms in some way also..always a possibility...I would leave that to Apple and VSL to figure out, but first...  try to create a brand new project in LogiPro using Au3 and see if it works normally or not.


  • ps - Just tried to create a new project using VePro.AU3 and immediately started getting wonky behavior with the plugin...so yea...something is broken with the plugin for sure.   GUI isn't redrawing correctly.  Also can't even use the the buffer muliplier control at all...  Well...I don't have any time to dig any deeper and this is not pressing for me so I will leave it to others to wort this out with Tech support....but I would say VePro.AU3 is not usable with LogicPro.AU3 until further updates from Apple and/or VSL.


  • So the official answer from VSL is that 10.7.5 has broken the AU3 Plugin, which is a shame to say the least.


  • last edited
    last edited

    @dfhage said:

    So the official answer from VSL is that 10.7.5 has broken the AU3 Plugin, which is a shame to say the least.
    Where is that official word?

  • I had an email from VSL support confirming it doesn't work, and there is no timeframe for a fix


  • last edited
    last edited

    @dfhage said:

    I had an email from VSL support confirming it doesn't work, and there is no timeframe for a fix

    Noted thanks.  I am rolling back LogicPro to 10.7.4 for this reason until further notice.  


  • Yes I get the same situation and the error dialog  - just confirming.

    Rats.


  • Hello, I desperately need help.  I need urgent help in the middle of work. M1 Mac Studio Apple M1 Ultra.

    I have deleted all folder MacintoshHD/Library/Audio/Plugins/Compoents just to be sure that Logic can start but it does not. It shows the stupid  Vienna Ensemble Pro AU3 Plugin may require an update. Please help me as I am fighting with this all day through.  Where, what is causing this problem? There is no plugin, I have removed it. 

    The more I cannot open the  Plugin Manager and I am stuck in  Updating Information about Audio Plugins  (This is Logic 10.7.5)

    The more I cannot start The Plugin Manager, it seams something is wrong and Logic remembers the AU3 Plugin. 

    Please help I am desperate and In the middle of my work

    Image

    Image

    Image


  • So disappointing. 😞

    I've filed a report about this on "official" Apple community channels since I couldn't find any report of this on Apple websites.  Feel free to click the "Me Too" button there if it's also impacting you.

    https://discussions.apple.com/thread/254563764


  • ErisnoE Erisno moved this topic from Vienna Instruments Pro on