Vienna Symphonic Library Forum
Forum Statistics

181,978 users have contributed to 42,198 threads and 254,643 posts.

In the past 24 hours, we have 4 new thread(s), 8 new post(s) and 45 new user(s).

  • (FIXED) Vienna Instruments: Complete Crash

    last edited
    last edited

    Howdy all,

    Today I was working in MainStage for awhile, where I use instances of the Vienna Instruments Pro plugin. I don't know what triggered it, but at some point, MainStage would crash completely whenever I tried to open the VI plugin on one of my channel strips. Same thing would happen if I tried inserting the VI plugin on a channel strip-- the application crashes immediately.

    Again, not sure what triggered this because I wasn't really tinkering in the VI plugin itself. Just at some point it failed to respond to any MIDI input and would crash when I tried to open it / insert it.

    Even though I wasn't working in Logic, when I then tested the plugin there, I got the same results.

    The standalone VI Pro applicatoin also crashes immediately for me upon trying to open it, but frankly it's been that way for a month or so now. But the plugin just started crashing for me today.

    Anyone able to point me in a helpful direction?

    ---------
    Here's what I've tried so far, but the problem still persists:

    • restart the application (Mainstage/Logic)
    • restart my computer
    • attempt to open the plugin in a new fresh project
    • rescan the plugin inside Mainstage/Logic's Plug-In Manager
    • install the latest version of Vienna Instruments Pro (from Nov 15)
    • erase Vienna Instruments Pro and re-install

    I am running MacOS Big Sur 11.6.1. Macbook Pro 2017.

    The complete problem report from the crash can be read here.


  • Well the VI Pro plugin is working now... and I have no idea why. I didn't tamper with it any further after leaving my last post. But it's a little scary because I don't know what caused it in the first place. And I can't afford to have something like that pop up out of nowhere again before/during a live show.

    The VI Standalone app still is crashing every time I try to open it though. But far far far less concerned about that.

    EDIT: Nevermind. It's all crashing for me again just as it was before. Anyone ever encounter a similar issue? What should I try next?

    EDIT 2: Alright I figured out the problem, and I'm a little embarrassed. Turns out the eLicenser key was not plugged in properly. Man, I hate dongles...

    Once I plugged it in all the way, things were loading again ok. Still, kinda weird, because in the past I'd get a warning message when it wasn't plugged in. It wouldn't completely crash Logic/MainStage like this.

    And again, the standalone VI app still crashes immediately upon trying to load. Oh well.