Vienna Symphonic Library Forum
Forum Statistics

182,061 users have contributed to 42,201 threads and 254,657 posts.

In the past 24 hours, we have 2 new thread(s), 8 new post(s) and 41 new user(s).

  • CPU usage problem/Clipping sounds for Vienna Synchron Steinway D-274

    Hello everyone, I just bought the D-274 recently and started to test the sound yesterday. 

    I'm using Roland RD-2000 as my audio interface (the digital piano itself has a built-up audio interface). I have a computer with Razen 5900X CPU, 64GB RAM and Samsung 980PRO SSD. I have a friend who also has a RD2000 with 16GB RAM and lower grade CPU. I tried to use his preset with only 4 microphone off, but there's a lot of buzzing/cracking sound. Especially when I tried to play something intense (not sure if it's related). Even when I turned off one more microphone, the problem till occurs. I've already checked all my setting including preload size.  I've also tried adjust the buffer size and it's still not working. (He sets 256 which I think there should be no reason I can not run at 256 anyway?)  I've tried it both standalone and in DAW (protools) and none has worked for me. 

    My cpu usage during my playing is always under 50-60% but the peak to 100% is quite often which the weird sound occurs. My friend also asked me to check the task manager which we found that I only get 3%-5% CPU usage all the time (except the time the program is loading samples). He said he (not only him but there're few others using the D-274) got 20-30% at least CPU usage in the task manager. This really has made me frustrated the whole last night since I've been trying to figured out the reason but got no answer. I really enjoyed the VST but I just want to make sure everything is settled before my first recording with it. 

    I've searched on the forum last night and found some who has similar issues. But some are solved by changing pre load (which I already tried all different preload size including the largest one). Is there anyone else who experienced and solve the problem?

    Thank you.

    Image

    Image

    Image


  • Hi,

    I also answer your email about this - but I wanted to post the answer here as well. I hope this helps!

    My best guess is that your friend has a CPU with faster single-core performance than your CPU, which is expected with a CPU with fewer cores (which run on higher base clock speed). You could either deactivate some mic positions or use a larger buffer size for your ASIO driver. Voice processing is always a single-core task.

    Another very effective workaround would be to load the Synchron Pianos Player multiple times with the same piano preset. And then, you split/load the individual mic positions on individual player instances. That way, your CPU can play to its strength (multiple cores). We are working on an option to make the Synchron Pianos player utilizing all available cores when it comes to voice processing (like a switch the user can choose to activate or deactivate). But that's a very tricky thing to do. Please give that workaround a try and let me know how that improves performance on your system.

    Best Regards,
    Andreas


    VSL Team | Product Specialist & Media Editing
  • last edited
    last edited

    @Andreas8420 said:

    We are working on an option to make the Synchron Pianos player utilizing all available cores when it comes to voice processing (like a switch the user can choose to activate or deactivate). But that's a very tricky thing to do. Please give that workaround a try and let me know how that improves performance on your system.

    Best Regards,
    Andreas

    Awesome! Really looking forward to that update. You're doing a great job.

    God Bless,

    David


    F308, D-274, 280VC, Bösendorfer Imperial, Vienna Imperial