Vienna Symphonic Library Forum
Forum Statistics

182,061 users have contributed to 42,201 threads and 254,657 posts.

In the past 24 hours, we have 2 new thread(s), 8 new post(s) and 41 new user(s).

  • [SOLVED] VI Pro 2 stopped responding to one specific keyswtich

    For many years I've kept a basic convention for my keyswitches in VE Pro 2, which are all in the octave below the end of an 88 note keyboard (I do this to trigger them from a little Nanokey that sits on the master controller).  By the Default setup in VSL nonclemeture, this starts at C0 going up to B0.  While I was setting up a new instrument today and setting all the keyswitches to my standard, something bizarre has happened - no keyswitch now responds to C0.  Anything C#0 upwards is fine.  I can see the midi getting though normally onto the VI Pro GUI keyboard - it flashes away as I hit C0.  So midi going in is ok, all other keywitches are ok, but C0 stubbornly refuses to switch.

    Moreover, it behaves like this now on every single existing patch, part of my templates for years.  I've not touched any of them, so its clearly a global setting somewhere that has gotten changed or something is corrupted.  I can see 2 keyranges top right of the GUI in VE Pro, and they are both set normally (not that I should be using them).  I've restarted VE Pro and indeed the entire rig, but no matter what I do C0 fails to switch.  Reinstall VI Pro perhaps?  Grateful for any and all help.

    VI Pro is on 2.4.16779 - Win 10 Pro.

    EDIT - updated to 2.4.17181, no change to behaviour sadly.

    EDIT 2 - tried player in Cubase and standalone, bypassing VE Pro completely  No change to behaviour.


  • Some progress, but not a blanket fix.  I've never used Matrix keyswitches, these are in purple.  By default, they are also set to C0 on my rig, so its a conflict.  If I move the matrix keyswitch down 1, I can then keyswitch the cell normally.

    Hooray, but - all my instances of VI Pro still have this conflict, and all my old projects are now not working correctly.  Until 2 hours ago, this conflict was never an issue, suddenly now it is.  Is there a global way to turn off Matrix Key Switches?  Or set the Cell keyswitches to take priority in a conflcit?  It seems like either of these solutions would fix the problem completely, but I can't see any setting or reference to it in the manual.


  • Hi noiseboyuk, 

    Can you please send such a song to support@vsl.co.at, so we can take a look? With a quick reference to this thread....

    Best,
    Paul


    Paul Kopf Product Manager VSL
  • Thanks Paul, but fixed this end.  I was having a slightly senior moment as I finally remembered I'd encountered this problem before, and moved my usual keyswitch position up one to avoid this very problem - several years on I now realise why it occured and I could have moved the Matrix keywitch instead.  Sorry for the hassle!

    So for any future forum searchers - if you find a keyswitch isn't working its likely a clash with the matrix keyswitches, indicated by a small hashed area at the bottom of the key on the keyboard.