Vienna Symphonic Library Forum
Forum Statistics

182,061 users have contributed to 42,201 threads and 254,657 posts.

In the past 24 hours, we have 2 new thread(s), 8 new post(s) and 41 new user(s).

  • all key switches set back to staccato after a pause or stop


    Lately I have a strange behaviour in my VI Pro 6 instances.

    Everytime when I stop or pause a playback in my DAW, all the VI Pro instances jump back to the first cell in my matrix, being staccato.

    The playback is normal, with all the correct keyswitches, but after a stop, they all go back to the first oen, staccato. That happens always after a start or pause. It looks like that cell is considered as the default one to start with.

    I Work with Presonus Studio One and the helpdesk doesn't know why this is happening. Could it be a VSL matter? Something that I've overlooked duriong my setup?

    Thanks for your help!


  • I don't know Studio One in depth, but many MIDI sequencers have an option to reset all controllers and/or send an "All Notes Off" command on stop. Another possible culprit is an option that returns the play-head to zero or the previous starting position after a stop command. 

    I would look out for something like that ... :-)


    /Dietz - Vienna Symphonic Library
  • Thanks a lot Dietz,

    Unfortunately, what you suggest about the controller reset or an "All Notes Off" command is not the case. I've contacted Presonus for that matter and they advised me to delete all the settings in that piece, start it again and check. Nothing changed...

    It has nothing to do with the position of the playhead either. It stays nicely where it was before the stop. Only the articulation keeps jumping to the first position in the matrix list. The odd thing is, that such behaviour never happened before and it doesn't reproduce itself when I set up a new piece for testing purposes. So it must have something to do with the actual piece and its settings. Strangely enough it comes back after deleting all the settings in Studio One. That's why I assume that it could be something that I accidentely fiddled with in VI Pro...



  • Hi Dietz,

    Almost by accident I came across the culprit of this misery. After some reasoning I had some suspicion that some controller with a hidden value might be the cause and indeed. All the tracks had a "Program Change" controller (which is not being used) with a value "0" (almost invisible because at the bottom). That controller provoked the position 0 of the instrument list, which is always a staccato in my setup. What I don't understand is that my instrument list and matrix cells are selected with key switches, NOT with program changes and key switch button is selected under the matrix list. And yet...

    I have no clue why or how the Progam Change controller was added. Maybe it is a standard insertion in the new Studio One 4 version. I'll have to check that out.

    The good thing is, problem solved and issue closed.

    Thanks for your cooperation.


  • Hi Jos, I had a similar problem using sonar. I fixed it by making sure the Y axis was set to keyswitch, not controller. Which sounds like what you did. It was very frustreting, but fortunately only seemed to affect some of my instruments.

  • last edited
    last edited

    Hi Michael,

    The most frustrating part was, that I couldn't possibly think of a logic cause. Since I never use Program Changes, I didn't think of that controller until I suddenly saw it in my piano roll. At the bottom of that window, the controller showed a 0 value. I remembered that the Matrix list can be commanded by Program Changes and by key switches (which I always use), so I decided to remove the redundant controller and at once the problem was gone...! As it happens so many times, the most impossible issues seem to be generated by the most stupid and trifling causes. The problem is to find them. 😠 And again the solutions are always there when you don't expect them anymore.

    In my setup, all instruments were affected (they all had (for some unknown reason) a Program Change controller).

    Thanks for your reaction,