Vienna Symphonic Library Forum
Forum Statistics

185,145 users have contributed to 42,379 threads and 255,428 posts.

In the past 24 hours, we have 2 new thread(s), 10 new post(s) and 55 new user(s).

  • When stopping playback in Logic, modulation is reset to 0 in VEP Kontakt instances

    Hello, I am trying to figure this out:

    I am using a multiport template for Logic, and thought it was a good idea to have emtpy midi clips for each instrument to balance and reset Modulation, Expression and Volume.

    In my clips I have created three data points, setting Volume to 100, Expression and Modulation to 64.

    On playback, all values seem to transmit to VEP, but when I stop playback, the Modulation in each Kontakt instruments drops to 0. I want it to stay at 64 even if the playback is not running in Logic.

    I have a Komplete Kontrol keyboard connected, but plugging this out has no effect. Any idea on where I could start looking to have the Modulation value hold it's value after pressing Stop?

    I had a look at this thread: https://www.logicprohelp.com/forum/viewtopic.php?t=100397
    and I have ensured that "Clip length" in unchecked in my region inspector.


  • last edited
    last edited

    @filipblaauw said:

    Hello, I am trying to figure this out:

    I am using a multiport template for Logic, and thought it was a good idea to have emtpy midi clips for each instrument to balance and reset Modulation, Expression and Volume.

    In my clips I have created three data points, setting Volume to 100, Expression and Modulation to 64.

    On playback, all values seem to transmit to VEP, but when I stop playback, the Modulation in each Kontakt instruments drops to 0. I want it to stay at 64 even if the playback is not running in Logic.

    I have a Komplete Kontrol keyboard connected, but plugging this out has no effect. Any idea on where I could start looking to have the Modulation value hold it's value after pressing Stop?

    I had a look at this thread: https://www.logicprohelp.com/forum/viewtopic.php?t=100397
    and I have ensured that "Clip length" in unchecked in my region inspector.

    This behavior is an unfortunate side effect of how ‚ÄúLogic Pro handles MIDI reset messages automatically and intelligently‚ÄĚ

    See the manual at page 2,131

    The problem has been reported to Logic, if possible please file a report with their developers.