Vienna Symphonic Library Forum
Forum Statistics

185,277 users have contributed to 42,390 threads and 255,477 posts.

In the past 24 hours, we have 3 new thread(s), 22 new post(s) and 54 new user(s).

  • VI Remote App not being recorded in Studio One 3

    I'm probably making some obvious mistake, but despite reading the VI remote manual, I can't solve this problem: When recording using Studio One 3.5 (haven't tried with other DAWs), the articulation changes I make using the remote app - successfully: I can hear them as I play and record - aren't being recorded into my track. The only way I can record articulation changes is if I use the keyswitches on my controller rather than the cells on the remote app (or in my DAW using the mouse). I have "enable direct and MIDI control" checked. Any ideas, anyone? 


  • Found this:

    Ben@VSL | IT & Product Specialist
  • last edited
    last edited

    @bbelius said:

    Found this:

    Thanks for the suggestion, but even after remembering to click the MIDI dump button after hitting record, the problem persists. As far as I can tell, I'm following all the steps in the video and the manual. I have no problem controlling my VI instruments with the remote app, but none of the changes are being recorded. 


  • Check if "Vienna Instruments Midi" midi-device is set as input to the recording channel.


    Ben@VSL | IT & Product Specialist
  • last edited
    last edited

    @bbelius said:

    Check if "Vienna Instruments Midi" midi-device is set as input to the recording channel.

    Thanks. That's at least gotten me half-way to where I want to be. I had to create "Vienna Instruments Midi" as an "external instrument" in order for Studio One to see it and receive input from it. The downside is I now have to select "any input" (i.e. all inputs) for any track I want to control with the VI app rather than just one of my keyboards. Studio One only lets you pick either a single input device for a track or "any" (i.e. all that are connected). This is a problem for me because lately I usually play two keyboards at once, controlling different instruments on different tracks simultaneously, e.g., a solo instrument controlled by my 49-key controller on one track and a piano controlled by my 88-key controller on another track. I was hoping Studio One would automatically record MIDI from the VI remote without having to get into that whole input selection conflict.  Thanks again. 


  • I can't tell you how to do this in Studio One.
    In Cubase I would do following to achieve this:
    1) Install loopMIDI (http://www.tobias-erichsen.de/software/loopmidi.html) -> virtual MIDI Cable
    2) Start LoopMIDI and open 1 virtual MIDI-Port (let's call the channel "loopMIDI")
    3) In Cubase setup your 2 VI instances and 4 MIDI-Channels

    4) In "Keyboard1Route" set input to your first Keyboard and output to "loopMIDI"
    5) In "VI Route" set input to "Vienna Instruments MIDI" and output to "loopMIDI"
    6) In "VI1" set input to "loopMIDI" and output to your first VI instance
    7) In "VI2" set input to your second keyboard and output to your second VI instance
    8) Activate Monitoring on all 4 MIDI-Channels and Recording on Channels "VI1" and "VI2"

    Last step: Find a way to do this in StudioOne ;)

    Best, Ben


    Ben@VSL | IT & Product Specialist
  • last edited
    last edited

    @bbelius said:

    Last step: Find a way to do this in StudioOne 😉

    Best, Ben

    Not to mention MacOS. That's the bad news. The good news is your suggestion nudged me to look further into solving it via MIDI channel assignments, which led me to an article about setting up a multitimbral instrument in S1, which got me nowhere until it accidentally led me to an aha moment: I can create a new track with only VI remote as the input, then select the VI instance I want to control as its output. Meanwhile, I can keyboard control that same instrument on its original track with whichever single keyboard I want to control it with. With both of these tracks record-enabled, it works! So thanks, Ben, for nudging me, Zenlike, to the solution to my problem 😊

    Syd