Vienna Symphonic Library Forum
Forum Statistics

184,988 users have contributed to 42,372 threads and 255,397 posts.

In the past 24 hours, we have 1 new thread(s), 6 new post(s) and 78 new user(s).

  • Plug In Scanning Issues

    I am new to VEP and I'm running VEP6 on a macbook pro on 10.10.5 (single machine) and with Cubase 9.5.  

    I first realized that my Sonic Academy Kick 2 VST was crashing VEP (it wouldn't even load) and so I rescanned the plugin folder.  On rescan, then Kick would scan correctly and work but then Soundtoys Panman wouldn't scan (the scan would crash when it got to Panman.  On restarting VEP then sure enough Panman wouldn't be there so I would rescan again and then this time Panman would scan fine and a different plugin would crash on scan and then not show up.  

    These VSTs all work fine in my other DAWs and I have no issue scanning them.  I have a hard time believing that the problem is with the plugins if one minute the plugin scans and works fine and then the next minute VEP crashes when it tries to scan the plugin.

    I reached out to support about this last week and they haven't addressed this question (though they have addressed other issues I have had).

    Has anyone else had problems with VEP6 inconsistently scanning plugins and randomly crashing on different plugins?  Any solution?


  • last edited
    last edited

    @mbira said:

    I am new to VEP...running VEP6 on a macbook pro...with Cubase 9.5.  

    I first realized that my Sonic Academy Kick 2 VST was crashing VEP (it wouldn't even load)...On rescan, then Kick would scan correctly and work but then Soundtoys Panman wouldn't scan (the scan would crash when it got to Panman.  On restarting VEP then sure enough Panman wouldn't be there so I would rescan again and then this time Panman would scan fine and a different plugin would crash on scan and then not show up.  

    These VSTs all work fine in my other DAWs...Has anyone else had problems with VEP6 inconsistently scanning plugins and randomly crashing on different plugins?  Any solution?

    Yes, new to the Vienna Ensemble, Vienna Instruments, Suite & MIR ecosystem. Really impressed by the whole package and the integration. Just working through the setup of VEPro, setting up the prefs and doing the plugin scan. VEPro does not seem to like the SoundToys plugins. I have done several VST scans on my primary DAW Windows 7 machine and it crashes VEPro everytime. 

    I have looked high and low for a graceful solution but I don't think there is one other than creating a separate directory for plugins that VEPro will not see. which means uninstilling SoundToys and reinstalling them in this new VST directory. Other users thinking about doing this, please make sure you check to make sure you still have access to your installers and backup the plugins you are moving just in case. Really hope there is a solution already out there before resorting to this workaround.

    It would be great if a VSL support person or Dev could chime in to give an update on this. I know they have been on the forum in the past year saying they were feverously working on a solution or a fix for this. A solution I would like to float would be to create a "blacklist" file solution much like Adobe has for Premiere Pro where there is a simple text file, in their case called "blacklist.txt" that you have inside the same folder as the suspect plugin/VST that contains the filenames that should be ignored by VEPro. The Steinberg solution I think would involve more Developer effort to complete. Adobe's solution is about as simple as it gets, just don't name the blacklist file the same as Adobe's!

    Thanks VSL. Great software. Really looking forward to exploiting the full potential of your suite of apps to control the instruments.

    -Andrew Stone


  • As I suggested in my previous post, I decided to create a new VST directory that would not be scanned by VEPro, reinstalled the offending SoundToys plugins into the folder, IDed the folder by my primary DAW, Nuendo and then Launched VEPro Server and it then managed to get through the rest of the VST plugin list and all is well.

    -Andrew


  • Im still on VEP PRO 5 latest update and it keeps scanning the entire Plugin folder 90pc of the time i open it. Random times it will load normally without scanning. It wasn't always like this. Did an entirely fresh install and updated  and still it's doing it. I find alot of the time it will do the vst scan and crash at the end of it, and after that i open it again and it doesn't scan and loads fine!