Vienna Symphonic Library Forum
Forum Statistics

179,368 users have contributed to 42,081 threads and 254,056 posts.

In the past 24 hours, we have 2 new thread(s), 13 new post(s) and 70 new user(s).

  • VEpro bug with Cubase expression maps

    As I want to create a bigger Expression map within Cubases, I cannot use notes, as I don't want them to be in the playable range of the keyboard. Well, then I thought, I'd use program change, but doesn't seem to work due to a VST3 limit (Steinberg actually denies that, well ...).

    Well, I am flexible, so I thought, why not take an unused CC insead, like CC 0 or 127. I got a lot of strange result with my expression map, which should have actually worked and I thoroughly learned how to build them by the manual. It took me half a day to figure out that it was actually VEpro that is changing the order of the CC and the note that is coming in! That is why every articulation change that is sent just befor the note (like it happens with attributes, or when you click on a note in the key editor) is being put after the note by VEpro. I could verity that by sending the midi to a midi monitor out side of Cubase. There, the order was as it is supposed to be, but looking at it within VEpro (Kontakt midi monitor) the order is reversed! There probably were good intentetions why to prioritize notes over CC data, but it makes the expressionmaps totally unusable to me.

    I am all for a quiet and respectful communication here, but as a long time customer, I must say I am really getting annoyed by all these limitations and malefunctions. It is not only VSL, but also Cubase and partly some plugins. I put days of work into figuring out how I can build a usable and intuitive template, but always something seems to be in the way of working as it actually should. Dear people form VSL, with all respect: Could you please comment on that. Why must you influence the order of midi data sent? Why cant that be played back as it was received? Thank you


  • I didn't want to edit my first post, as there were other problems, so I want to stay with what I said. But now it found out, it might even be Kontakt that is reversing this order ... I saw, if I send notes as keyswitches (instead of CC 0), the order is as it is supposed to be, but as soon as I convert this to PC or CC or whatever (not notes), it gets reversed again - this time in Kontakt! So, I might have been wrong about VEpro doing this to the midi, it might just be Kontakt (or both) ... anyway, I would still like to hear, if the order of midi messages gets reinterpreted from VEpro plugin or host.


  • Hello Fritz, 

    Always a pleasure to read your input. MIDI information is not changed by VE PRO. 

    Best, 
    Paul


    Paul Kopf Product Manager VSL
  • Hi Fritz,

    Funnily enough, I have actually experienced exactly the same issue. I was hoping to make use of the FlexRouter script for Kontakt, though I have actually experienced this by just using the MIDI Monitor multi script within Kontakt.

    I'm using the same use case as you; Cubase MIDI track with expression map sent to a VEPro input, with Kontakt hosted within VEPro6 on the same machine. Specifically:

    • If Kontakt is hosted in Cubase alone, CC information sent from Cubase correctly appears before a Note On
    • If Kontakt is hosted in VEPro, CC information sent from Cubase appears to reach Kontakt after a Note On reaches it
    • Additionally, when Kontakt is hosted in VEPro, CC information is sometimes received multiple times

    Paul - I've searched around for this issue here and over at VI-Control in the past. Since this isn't something I'm seeing coming up a lot, is it possible Fritz and I are seeing some kind of latency through VEPro or Kontakt itself?

    Apologies if this appears more towards a Kontakt question, but I'm not fully understanding why it would receive data in a different order when hosted in VEPro (I could understand different speeds). Worth noting I don't experience this kind of latency with Vienna Instruments Pro.

    Thanks in advance.


  • Hi Fritz and Pheonix52gx,

    To what have you set the Buffer Multiplier in the VE Pro Server Interface plug-in?

    Does it make a difference if you set this to 0 Buffers?

    Best, Marnix