Vienna Symphonic Library Forum
Forum Statistics

181,802 users have contributed to 42,186 threads and 254,601 posts.

In the past 24 hours, we have 6 new thread(s), 32 new post(s) and 51 new user(s).

  • VEP 6 goes into sleep mode in Bitwig 2

    I'm testing VEP 6 in Bitwig 2 on Windows 10.  The way I set up tracks, I have the main VEP Pro plugin on one track, with all outputs muted.  I then make a Bitwig 2 track for each VST instrument on VEP.  Each of these Bitwig 2 tracks has and VEP event input plug, followed by a Bitwig 2 Audio Receiver that extracts its audio from the main VEP Pro plug.  This way, I have individual BW 2 tracks that behave very closely to what I would have if the VSTi were inserted directly in the host as usual:  this track can be individually routed and it carries its MIDI clip around as expected.  Note that in this setup the main VEP Pro plug doesn't receive any MIDI input at all. 

    All the routing works, except that if I let the DAW sit idle for a while, VEP becomes unresponsive.  Nothing comes out of it unless I send some MIDI to the main VEP Pro plug.  It then wakes up and everything is fine.  So I made a quick BW2 widget that sends a CC message to the VEP Pro plug every measure to make sure it stays awake.  It works.  I'm just curious if this is expected behavior for VEP 6.  Does it happen with other hosts, or should I report it as a bug to the Bitwig devs?


  • Hi,

    I'm researching a switch from Cubase 8.5 to Bitwig. Seems you have a reasonable workaround for this issue. Are there any other mentionable issues with VEP6 you are aware of?

    In Cubase I use a lot of VEP6 (VST3) instances with track presets. Most of the VEP channels are individualy routed to Cubase channels (mostly 8 to 12 channels per instance). All firing up with a template. Would this workflow work in Bitwig2?

    Thanks in advance

    Martijn


  • last edited
    last edited
    [color=black][size=9]

    @Another User said:

    All the routing works, except that if I let the DAW sit idle for a while, VEP becomes unresponsive.
    I've been able to counteract this by right-clicking the VEP 6 master device and the Event Input devices, and toggling the "auto-suspend" option to "off". Does this work for you and eliminate the need for sending midi events to keep the devices awake?[/size][/color]

  • Yes that is how I got it to work.  You have to set each of the VEP vst plugins to autosuspend off in the Bitwig right-click menu for the device.  Then you have to hit "Save as default preset", at the bottom of the right-click menu.  From there on you're all good to go.