Vienna Symphonic Library Forum
Forum Statistics

182,064 users have contributed to 42,202 threads and 254,660 posts.

In the past 24 hours, we have 3 new thread(s), 11 new post(s) and 40 new user(s).

  • MIDI Ports and Graphic Performance Problem

    Hi,

      After much troubleshooting I've encountered a reproducable problem with the VE Pro Plug in in Cubase on a Mac.  Basically certain MIDI ports in VE Pro produce glitches in the graphics in cubase, where the cursor will slow down and there will be a lag in it's overall graphical performance depending on how much MIDI data is going through the port  This problem occues with the most recent updates of VEP 5 or VEP6.  I've tried it with Cubase 8.5.15 and 8.5.20.  I've tried this on 2013 Mac Pro 8-core, Imac, and even Hackintosh with the same result.  All Macs are on Yosemite 10.10.5.  This problem only occurs on the plugin side of the program, it does not have to be connected to a server.  ASIO Guard is disabled all VEPro plugins. Here is the test:

    1) open an empty 24b, 48k session in cubase

    2) create 50 midi tracks

    3) record just a few seconds of CC1 and CC11 to all of the tracks at once

    4) now in the rack add an instance of VE pro plugin vst3 to allow for multiple midi ports.  go ahead and activate 32 of them in the preferences and reload plugin if necessary.

    5) assign all 50 midi tracks to VEP port 1 (you can do this by selecting all the tracks and holding down SHIFT+OPTION when you select the midi output)

    6) play over your regions and note how the cursor and graphical performance is.  It should be good.

    7) assign all 50 midi tracks to VEP port 15

     

    8) play over your regions and see how graphics are handled.  The cursor will most likely studder and lag trying to go over the regions.  

    This problem occurs on many ports the higher you go, usually.  It seems to get consistently worse as you increase from Midi port 1.

    This problem makes it very difficult to work with larger templates as the graphic performance is comprimsed and slow even with powerful graphics cards.

    Any thoughts?

    thanks!


  • Hello,

    I am responding a few years after your initial post.  I am having similar issues in Cubase with VE6.  I get intense lag in my midi key editor window when there is lots of cc data and expression map recorded.  Did you ever find a solution to your lag issue?

    Sam

    Win10 Home _64

    Cubase 5.5.3

    SSD for OS and VSL Libraries

    16GB Ram@3200Ghz

    Ryzen 7 2700x@4Ghz


  • Hi,

    Were you able to fix the issue? I'm going through the same exact problem, already tried all the possible solutions, nothing seems to be working. Any luck on your end?

    Many thanks!


  • Having exactly same problem on Cubase 11 & VEP 7. Did you fixed it?

  • Hello,

    you can try these:

    • disabling unwanted MIDI chasing (unchecking "Preferences > MIDI > Chase events")
    • disabling MIDI reset (unchecking "Preferences > MIDI > Reset on stop" and checking instead "Never reset chased controllers")
    • simplifying your MIDI CC curves by thinning out MIDI data in your tracks (MIDI > Functions > Thin out data)


    Mac Studio M1 Ultra macOS Ventura 13.4 Studio One 6.5