Vienna Symphonic Library Forum
Forum Statistics

181,683 users have contributed to 42,180 threads and 254,554 posts.

In the past 24 hours, we have 2 new thread(s), 11 new post(s) and 52 new user(s).

  • VEP6 - Logic and Cubase huge performance difference

    Since installing VEP6 I've been refreshing the Cubase and Logic templates I run on my W10 PC slave.

    I've found there to be a huge performance difference between the two DAWs. However I set them up in completely different ways, so I'm wondering if I've missed something obvious in the process.

    Cubase 8.5

    Connected to a VEP slave running 5 instances - one for each orchestral section - using Expression Maps to control articulations.

    Logic X 10.2.4

    Connected to VEP using one instance per instrument - using Skiswitcher to control articulations.

    Both templates are set to run EW Hollywood Orchestra with exactly the same samples loaded and the same number of Play VI's.

    Both templates, when unconnected, run at 0% CPU and take up around 19GB of RAM.

    However when connected to Cubase at a buffer of 256, the CPU shoots up to 96% and stays there, I can only make any use of the template if I raise the buffer setting in Cubase to very high levels. Even then it can choke.

    When I connect Logic at a buffer of 128, the CPU rises to just 3% and can handle the full orchestra playing without breaking a sweat. (The connection time is virtually instant now too, which is a huge bonus).

    I've tried various different combinations of thread counts and buffer settings, as well as disabling a few instruments in VEP but it barely makes any difference in Cubase, it appears to be purely the act of connecting that causes the permanent CPU spike.

    For there to be such a massive difference, I can only think I've done something wrong somewhere, any suggestions on what it could be?


  • Hi Jon,

    Make sure you have Asio Guard disabled in Cubase 8.5 for the Vienna Ensemble Pro 6 plugin as that can cause performance issues. To do this, go to Devices/Plug-in Manager and select Vienna Ensemble Pro that shows VST3.65 as the VST version and choose at the bottom "inactive" for Asio Guard. You may need to click on the small "i" on the bottom left for the bottom panel to display the Asio Guard information to change it from Active to Inactive.


  • Hi Austin, thanks for the reply.

    I already have ASIO Guard disabled, no difference there either unfortunately.


  • I'm surprised to hear such a big difference in performance. What is your thread count set per instance in VE PRO 6? Make sure you are spreading your processor out properly on that front.


  • Hey Austin,

    Yep, I've tried every variation of thread count I can think of. It doesn't really seem to make much difference.

    After much testing, it appears it's only when VI's are loaded into VEP that the problem occurs in Cubase. If the instances are empty there isn't a dramatic rise in CPU usage.