Vienna Symphonic Library Forum
Forum Statistics

182,161 users have contributed to 42,207 threads and 254,681 posts.

In the past 24 hours, we have 1 new thread(s), 14 new post(s) and 44 new user(s).

  • Cubase can only see 32bit VE Pro on slave, not 64 bit - help!

    Hi everyone,

    I've been pulling my hair out about this, and can't understand what is happening. I have Cubase 64bit 8.5 on my master, connected to a slave running VE Pro server. The VE Pro plugin on Cubase will only recognise a 32bit metaframe on the slave, not the 64 bit one. 

    Everything has been updated to the latest versions, and I am running latest Win 10 (64 bit) i7 with 16Gb RAM on the slave, and OSX 10.11.6 with 32Gb RAM on a 12-core Mac Pro. VE Pro is the latest 5.4.1.

    I have ensured that "Advertise on local network" has been ticked in the 64-bit VEP Pro.

    This was working perfectly before I had to re-install windows on the salve, so I assume something has happened. I work with complex orchestral templates, so the thought of being limited to 3.5Gb RAM fills me with dread! 

    Many thanks in advance,

    Bruno


  • Hi Bruno, 

    Did you switch off the Firewalls?

    Best,
    Paul


    Paul Kopf Product Manager VSL
  • Thaank you Paul, this has worked! Strange that it worked ok with the 32bit version though, and that I didn't need to do this when I previously set up VEP Pro a month or two ago.

    It does leave my slave (which is connected to the internet) in a very dangerous position. Ranther than turning eveything off, can you tell me specifically how to justr allow communiucation between the master and slave?

    Thanks again for getting this working.

    Bruno


  • Hello Bruno, 

    If you have deactivated the Firewalls on your Windows machine, make sure that these ports are open: 

    - 6472 (TCP)
    - 6473 (TCP)
    - 6474 (UDP)
    - 6475 (UDP)
    - 6476 (UDP)
    - 6477 (UDP)

    1) Click "Start" and type "fire" in the search window 

    2) choose "Firewall with Advanced Security" 

    3) Click "Inbound Rules" in the upper left corner of the window

    4) Click "New Rule".

    5) Choose "Port", then "TCP" in the next window, and enter the ports. 

    Do the same for the UDP ports.

    Best, 
    Paul


    Paul Kopf Product Manager VSL
  • Ok, I've figured this out. You have to put a specific rule allowing connections for VE Pro in Windows firewall.

    It might be worth adding this to the manual/setup instructions, as without the above being done, VE Pro will not connect in 64bit on WIn 10 systems.

    I hope this helps somebody else.


  • Thanks for your reply, Paul

    Do you know if this has changed recently? As it stands, this will stop anyone using VE Pro 5 with Windows 10, unless they happen to see this thread and follow those instructions, as there's nothing in the manual about this. I spent a day yesterday trying everything I could think of, including a reinstall.

    Might be worth making a sticky so that anyone else using Windows 10 won't need search in vain for an answer, and certainly making it a necessary step to sort the firewall settings as part of the installation instructions in the VE PRO manual. It would also save you answering that question to everyone installing on Win 10.

    For now, I'm glad it's back and working.

    Thank you.