Vienna Symphonic Library Forum
Forum Statistics

181,981 users have contributed to 42,198 threads and 254,643 posts.

In the past 24 hours, we have 4 new thread(s), 8 new post(s) and 48 new user(s).

  • PSA re: macOS Sierra and VE Pro Server

    If you reinstall VE Pro after upgrading to macOS Sierra (public beta) then you will get a crash due to code signing errors when running VE Pro Server (either 32- or 64-bit).  This is due to a more strict code signing process that needs to be addressed by developers.  

    This can be fixed by codesigning the apps locally.  You can do this by executing the following terminal commands:

    sudo codesign -f -s - /Applications/Vienna\ Ensemble\ Pro/Vienna\ Ensemble\ Pro\ Server.app/Contents/MacOS/Vienna\ Ensemble\ Pro

     

     

    sudo codesign -f -s - /Applications/Vienna\ Ensemble\ Pro/Vienna\ Ensemble\ Pro\ Server\ \(64-bit\).app/Contents/MacOS/Vienna\ Ensemble\ Pro


  • This is still an issue with VE Pro 6.  Same solution as listed above works.  


  • Just upgraded to Sierra and my VE Pro 5 servers are still crashing continously, even after running the two terminal commands you posted. Any other ideas?


  • This problem was fixed for VE Pro 6.  You might want to ask support if VE Pro 5 supports macOS Sierra.


  • Good to hear, thanks for the response. I actually did purchase VE Pro 6 shortly after posting my above question... and now eLicenser Control Center is crashing on me every time I try to enter my new Activation Code (so now there's a new problem preventing me from running VE Pro). Have been troubleshooting this now for awhile with no avail. It's just one of those days.


  • last edited
    last edited

    Hi jhilsen01,

    Please check that you are using the latest versions of VE PRO and eLCC.

    Do you get any crash reports or error messages? Please send those to support@vsl.co.at, maybe we can find out more. No known troubles with OS Sierra.

    Best,
    Paul


    Paul Kopf Product Manager VSL
  • Hey Paul, thanks for the comment. Getting the latest versions of VE Pro and eLCC was the first thing I tried and that did not resolve the issue. I sent my eLCC crash report to Steinberg and am waiting to hear back from them.

    My solution to get everything working for me in the meantime was this: buy VE Pro 6, and install eLCC on a friend's computer so I could put the license on my USB dongle through that.


  • I am getting hard crashes with VEP6 AU plugin with LPX (all latest version os OSX and VEP).  The crash always happens when I open the plugin window.  This is not consistant but when the crash does happen it always reports VEP as the culprit.  

    I also noticed that running Play5 VST on this mac inside the VEP server causes a crash.  That is possibly a play issue but regardless one must avoid Play5 VST on the OSX side in VEP.

    MP5,1 12 core 64gigs of ram.  

    Chris


  • Hi Chris, 

    Thanks for reporting.

    As always: Please send the crash report with a short reference to this thread to support@vsl.co.at!

    Of course we assume that you are also using the latest version of PLAY (please confirm, with version number). 

    Thanks, 
    Paul


    Paul Kopf Product Manager VSL
  • Thanks Paul. I will send those tonight. Yes play is newest version which is 5.0. The VST crash on mac has been duplicated and confirmed by other users. I'm more concerned with the LPX crash. Chris

  • last edited
    last edited

    I am having the same issue. VEP6 just keeps crashing on start after updating to Sierra.

    tried to codesign the app, but got this:

    "Oscars-Mac-Pro:~ Oscar$ sudo codesign -f -s - /Applications/Vienna\ Ensemble\ Pro/Vienna\ Ensemble\ Pro\ Server.app/Contents/MacOS/Vienna\ Ensemble\ Pro --deep

    /Applications/Vienna Ensemble Pro/Vienna Ensemble Pro Server.app/Contents/MacOS/Vienna Ensemble Pro: replacing existing signature

    xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun

    /Applications/Vienna Ensemble Pro/Vienna Ensemble Pro Server.app/Contents/MacOS/Vienna Ensemble Pro: the codesign_allocate helper tool cannot be found or used

    In subcomponent: /Applications/Vienna Ensemble Pro/Vienna Ensemble Pro Server.app/Contents/PlugIns/bearer/libqcorewlanbearer.dylib"

     

    @dbudde said:

    If you reinstall VE Pro after upgrading to macOS Sierra (public beta) then you will get a crash due to code signing errors when running VE Pro Server (either 32- or 64-bit).  This is due to a more strict code signing process that needs to be addressed by developers.  

    This can be fixed by codesigning the apps locally.  You can do this by executing the following terminal commands:

    sudo codesign -f -s - /Applications/Vienna\ Ensemble\ Pro/Vienna\ Ensemble\ Pro\ Server.app/Contents/MacOS/Vienna\ Ensemble\ Pro

     

     

    sudo codesign -f -s - /Applications/Vienna\ Ensemble\ Pro/Vienna\ Ensemble\ Pro\ Server\ \(64-bit\).app/Contents/MacOS/Vienna\ Ensemble\ Pro