Vienna Symphonic Library Forum
Forum Statistics

184,538 users have contributed to 42,365 threads and 255,344 posts.

In the past 24 hours, we have 0 new thread(s), 6 new post(s) and 62 new user(s).

  • VEP crashes after connecting to localhost.

    last edited
    last edited

    I have created a metaframe with all my Kontakt 5 instruments, and created a Logic project linked to all the instances.

    1. I load the metaframe in VEP.
    2. I then open the corresponding Logic file.
    3. VEP starts saying (Connected localhost) on all the instances.
    4. This goes fine up until the last instance. VEP then crashes.

    I have tried every possible combination of settings for buffer, preload and core use in both Logic, Kontakt and VEP.

    The last thing I did was to buy to super-fast external SSD-drive to place the samples on, in case the loading was to slow for samples when connecting to logic.

    I have to connect every Logic instrument to VEP manually each time I open a project, and I fear that VEP is useless to me.

    I have been at it since I bougth VEP over a month ago. Can you please help me out? I recently bought a new mac and I get nowhere.

    Please see attatched Crash report.

    Reguards,
    Eirik

    CrashReport.txt-1696293463349-87qdb.txt

  • Hi When you save a project in any DAW all plugins and their status is saved in your song/ project! Try to open a project in LOGIC where you have used VEP as step one! If you want to load a metaframe do it as step two!! i hope it will Work for you! THank you Steen P.S Memoryram is very important! Check If you have at least 16GB. KONTAKT is heavy duty on ram! If you dont have enough ram your software will crash!

  • Hi Steen,

    Thank you for answering, even though I didn´t quite get you.

    What do you mean using VEP vs metaframe? When I select VEP as an instrument in Logic I only get to choose from the metaframe?

    Or do you mean that I should open Logic first, instead of opening the metaframe first?
    I have tried that, and nothing happens. I have to manually reconnect each instrument in Logic to the corresponding metaframe instance.

    Hope you can answer this, your help would be much appreciated! Neither the people at NI, Vienna or Berlin (the library creating the problem) seems to be able to help.

     

    Cheers,

    Eirik

    (I have 40 GB RAM).


  • last edited
    last edited

    @eirikbj said:

    Hope you can answer this, your help would be much appreciated! Neither the people at NI, Vienna or Berlin (the library creating the problem) seems to be able to help.

    I believe you received this information in an email case already, but this is clearly a case of a crashing script (due to a stack overflow) within Kontakt. Your library developer should be able to help you out.

    Thanks,


  • Hi Martin.

    Iǘe been in contact with Berlin, that seems to be the affected library, and they suppose it is a bug with the metaframe. They tell me to put together a new metaframe, but I refuse to do that 2 hour work if something else is the matter.

    I must say I am a bit frustrated that you, NI and Berlin are all putting the blame on someone else.

    Eirik


  • OK, Martin, I did it.

    So here is my answer to NI after being in contact with them.

    "I remove all Berlin instances in VEP and disable all VEP plugins in the corresponding tracks in Logic.

    For each try I:
    1. Close both Logic and VEP
    2. Open VEP and load a new instance.
    3. Reload the plugin in Logic.
    4. Save and close Logic.
    5. Save and close VEP.
    Each time this goes well (after try A), I also restart the Mac to ensure there is no memory residue in ram.
    And: Whenever I say “It chases” I refer to VEP, not Logic.

    A:
    All goes fine including the last instrument, "Bassoon 2”
    However, If I restart the mac and then try: It crashes.

    B:
    So I try to delete Clarinet 1 and reinstall Bassoon 2, without restarting: It crashes.
    I restart: It crashes!!!

    C:
    I now delete Clarinet 1, Clarinet 2, Bassoon 1 and Bassoon 2: it works.
    I restart: I works.


    Now for the fun part:
    D:
    I delete Bassoon 2 (Bassoon 1 still not connected), and reinstall Clarinet 1 and Clarinet 2. I crashes!!

    E:
    I delete Oboe 1 and Oboe 2 It works.
    I restart: It works.

    F:
    I delete Carinet 1 and Clarinet 2, and reinstall Bassoon 1 and Bassoon 2.
    I restart: It works!!!

    I can now reinstall the four last instruments and it works. But if i close and reopen Logic and VEP it crashes.

    Conclusion:
    It is not a single instance that makes VEP crash, it´s the load of samples.
    I have 40 GB of RAM, and the load of samples makes the total “Memory Used:” be 23,47 GB, so it´s not my hardware.
    And: It is no problem for VEP to load all instances, It is when Logic is done connecting to VEP, something makes VEP crash.

     

    Eirik


  • Is the crashlog always the same as in your first post?

    This shows Kontakt is causing a stack overflow in a processing thread that appears to be parsing some script:

    Thread 35 Crashed:
    0   libsystem_kernel.dylib        0x00007fff92cc0002 __pthread_kill + 10
    1   libsystem_pthread.dylib       0x00007fff88a945c5 pthread_kill + 90
    2   libsystem_c.dylib             0x00007fff8f5e2787 __abort + 145
    3   libsystem_c.dylib             0x00007fff8f5e3066 __stack_chk_fail + 200
    4   Kontakt 5.MusicDevice.component0x0000000119be1c73 BEngine::SetEngineParAsync(bool, BEngine*, BParTag, int, int, int, int, char const*, char const*, BParVal, int, bool, BParProperties::rep_mode, bool*) + 1171
    5   Kontakt 5.MusicDevice.component0x0000000119a76441 BScriptParser::DoSetEnginePar(int, int, int, int, int, bool) + 737
    6   Kontakt 5.MusicDevice.component0x0000000119a64461 BScriptParser::RunStatementList(MPrsStatement*, int*) + 20705
    7   Kontakt 5.MusicDevice.component0x0000000119a75468 BScriptParser::RunCallback(int, BCallbackEvent*) + 328
    8   Kontakt 5.MusicDevice.component0x0000000119c3a222 BEngine::RunEvents(int) + 5170

     

    If you can reproduce this crash, with the same crashlog for the crashing thread, this most likely is a bug in either the library developers script, or in Kontakt itself.


  • Have you tried trashing your preference files for Logic, VEPRO, and Kontakt?


  • Did you ever get this figured out?? I'm having the same trouble. I also have BWW in my metaframe.


  • I also have the same problem and have BWW in my VEPRO template. Like you I have more ram than being used in VEPRO, around 70-80% ram usage with 64GB ram in total

    As mentioned by Matt here, did you find a solution to the problem?


  • Has anyone found a solution to this problem? I am having this too.


  • Same issue here... with cubase Pro 8.5 


  • Hi, 

    Are you getting the same crash reports?

    If not, please send your crash reports to support@vsl.co.at, so we can analyze further. 

    Thanks, 
    Paul


    Paul Kopf Product Manager VSL
  • Same problem here using Cubase Pro 8.5.20 ... happens sproadically but I'm at a complete stand-still at the moment if I want to use one of my PC slaves

    Image


  • Hi oxblood, 

    Please send more information, best including crash reports and log files, so that we can check. 

    Find those log files here:
    OS X: /Users/USERNAME/Library/Application Support/VSL/Vienna Ensemble Pro/logs
    WIN: C:\Users\USERNAME\AppData\Roaming\VSL\Vienna Ensemble Pro\logs

    (On WIN, this folder is a hidden system folder, make sure that you see it: Organize => Folder and Search Options => "View" Tab) 

    Thanks,
    Paul


    Paul Kopf Product Manager VSL