Vienna Symphonic Library Forum
Forum Statistics

185,273 users have contributed to 42,390 threads and 255,477 posts.

In the past 24 hours, we have 3 new thread(s), 23 new post(s) and 54 new user(s).

  • Tips on making VE Pro and Mir Pro need less processing power

    Hi

    I am looking for tips to make VE Pro and Mir Pro need less processing power.

    I am using windows 7. Intel Core i3-2130 CPU @3.40GHz 8GB RAM 64 bit

    I am using Cubase in combination with VE Pro and Mir Pro

    I now have a set-up in which all Dimension strings are positioned differently in Mir Pro, which, as you can imagine, is asking an awful lot of my processor. In heavily orchestrated passages I am hearing annoying clicks on the attack of notes (and it's not caused by clipping). When I export the audiomixdown the problem seems to vanish as the audio is clean.

    I now have a thread count of 2 per instance, 8 MIDI Ports 32 audio outputs and inputs. Will changing any of these variables have any effect for me?

    In Mir Pro I have a latency of 1024 and an impulse response cache size of 5GB (maxed).

    I would appreciate some advice on which things to adjust in order to make my operation run more smoothly

    Thanks in advance

    Pieter


  • Hi Pieter, 

    How many instances are you using?

    The less instances, the higher you should set the Thread count per instance (I´d actually always start with the highest setting). 

    Are you using SSD drives and VI PRO? => Maybe try to increase the pre-loading time in the Directory Manager. 

    Also, what are your settings in the VI PRO Settings?

    Best, 
    Paul


    Paul Kopf Product Manager VSL
  • Hi Paul

    Thank you for your response!

    I am using only one instance of VE Pro and have allready maxed out the number of Thread count (to 4).

    Increasing the preload size helped, though I am still hearing some cracks here and there..

    I have my added my VI Pro settings in attach.

    Best regards

    Pieter

    Image


  • Hello Pieter,

    What did you change your Preload settings to?

    Did you also increase the thread count in the VE PRO Settings?

    If the cracks occur, does that happen with high polyphony? => Increase the polyphony and "voices settings". 

    Are only VI PRO instances involved?

    Best, 

    Paul


    Paul Kopf Product Manager VSL
  • Hi Paul

    I have changed my Preload settings to 8192

    I have increased the thread count in VI Pro and VE Pro to 4

    The cracks do occur with high polyphony, I have increased the Maximum Voices and Instance voises to Max, changing the preallocated voices seems to only worsen the problem.

    There is in fact only one instance of VI Pro involved.

    I've also tried increasing the buffer from 2 to 4. These things help but don't eliminate the problem.

    I think I'll just have to face the fact that my Desktop simply isn't strong enough to run all of the dimension strings in mir pro...


  • Hi Pieter, 

    I´m afraid it could well be that your computer is reaching the limits.... maybe time for a faster slave computer?

    Best, 
    Paul


    Paul Kopf Product Manager VSL
  • Hi Paul

    I have considered that but that would mean I'd have to buy a second license for the Dimension Strings, right?

    Best regards

    Pieter


  • Hi Pieter, 

    You could also just transfer your Dimension Strings onto a second key and use this key on your second computer. You can always use one license on one key at a time. 

    Best, 
    Paul


    Paul Kopf Product Manager VSL
  • Ok,

    I will try out making my better performing laptop a slave.

    Thanks for everything

    Pieter