Vienna Symphonic Library Forum
Forum Statistics

182,159 users have contributed to 42,207 threads and 254,680 posts.

In the past 24 hours, we have 2 new thread(s), 14 new post(s) and 46 new user(s).

  • (SOLVED) Audio Dropouts with VEPRo


    I'm a bit new to VEPro. I bought VE many moons ago, then packed down my studio for several years whilst building work happened. Now I've got my space back, have upgraded, and am building a system of 3 machines - though I've only connected the DAW and one slave so far, till I understand what I'm doing.

    They look something like this:

    DAW: i7 6 core 3.4GHz, Radeon HD6450, Echo Layla 3G, 64 GB RAM, 4 SSD drives, Cubase 7.5

    Slave: i7 4 core 2.66GHz, ATI AEH4350, 24GB RAM, SSD drives for system and Vienna - hard drives for other samples

    The problem is I'm getting constant audio outages in the stream coming back from the slave. Not crackling and popping, but periods of 0.5 to 1sec where the audio cuts out. If I'm playing a long enough sustain it does come back after the outage, so it would seem to be something taking priority over the audio, rather than the plugin stopping producing it.

    It doesn't matter whether I load VIPro or 3rd party plugins. Nor does it seem to matter how I set the threads, buffers, or my graphics card. So far I've only ever loaded one or two instruments, so it's not that I'm pushing the system to its limit. Sometimes it does settle down. Yesterday, for instance, I reduced the threads on the slave to 4 for each instance (I think each core does hyperthreading, so 8 cores appear in device manager) and had a couple of hours without a glitch, so I thought I'd solved it, but today that isn't helping at all.

    When I play instruments based entirely on the DAW there isn't an issue at all, so I'm thinking it's a problem on the slave, or with the connection, rather than a system-wide issue - but the machines ping each other just fine. I am using Synergy to share a mouse and keyboard, but that was never an issue when I last ran VE. The only thing that looks even slightly odd is that the CPU indicator in the corner of VEPro can get up to 30% for running one Kontakt instrument;  this is with intense instruments such as 8DIO Requiem, but still seems a little excessive, when I'm only playing a monophonic line.

    Any ideas?

  • I am getting the exact same thing using Logic X 10.0.5. Master is Mavericks 3.46Ghz 6 core Xeon Mac Pro with 24Gb of ram 256Gb SSD for system drive and 750Gb WD Black for samples drive. Slave is Windows 7 Ultimate Dell T7500 with dual X5560 2.8Ghz Xeon's 24Gb system drive is 150Gb WD Velociraptor and 300Gb WD Velociraptor sample drive. I think I have narrowed it down to my network cards. Computers are direct connected with CAT 6... Dell has a cheap Realtek Gigabit card and the Mac no longer supports jumbo frames after upgrading to Mavericks. This setup worked fine before so I am assuming its the loss of jumbo frames... am I correct in this?. I just ordered 2 brand new Sonnet Presto PICe Gigabit cards that will arrive Monday and can report back then. Thanks!

  • Thanks for that. I really am a complete idiot when it comes to computing - I had no idea about jumbo packets. So I checked the settings of my LAN adaptors, and discovered that jumbo packets were disabled on both machines. I've enabled them and the audio outs seem to have immediately improved dramatically. They're not gone altogether, but I now seem to get one every few minutes, whereas I was getting several every minute before. Any further suggestions would be welcome, as I still hope to eliminate the problem. I've checked the connection diagnostic in device manager, and both machines claim to be running fine at 1Gb.

  • What size did you set them to? if they can both do 9k try that and see if it gets better.

  • I'm getting this EXACT same thing. My slave is a PC i7 nice processor, my slave is an i5 3570k, neither using too much memory or processor, but getting these (seemingly network) dropouts or surges. I will try to see if I can figure out this packet thing in the meantime.

  • Well, just set the PC and Mac to 9000k on the mac and jumbo frame on the PC. Didn't help.

  • Are you running Mavricks by chance? Seems this is when all my issues started

  • No, but go figure. As a last resort I changed the cable, and it's working for the most part :/

  • Thanks again DRC Music,

    As it happens, I was just having a lucky few minutes last night. Tried it this afternoon, and things were worse than before, even with the largest jumbo frames enabled. But then I decided to connect the computers directly to each other, and I've had a couple of hours where I haven't been able to make the slave machine glitch once. So the solution is probably a new switch. Annoying, since the one I have claims to support jumbo frames, but at least it's not the biggest expense in the world.

  • My new network cards arrive tomorrow and support 9K jumbo frames and will be directly connected with no switch/router... I hope its solves all my issues

    Glad you made some headway! [:)]

  • Turns out I'd been even more bone-headed than not knowing about jumbo frames. My static ip addresses simply hadn't stuck, and I didn't realise. The first thing I did was go and assign addresses, so I assumed that was sorted. But today I started getting just occasional glitches even with a direct connection between machines; so in desperation I completely retraced all my steps. When I went into the ip4 properties, it turned out that DHCP was turned off, and the 'use this address' option was selected, but the box for the number was blank - on both machines.I tried putting it back in, but every time I left the properties window and came back, it was gone again. I have no idea how the machines were even talking to each other, but it must have confused the heck out of my switch.

    The only thing I could think was that I had attempted to assign the machines the same IP addresses that they had been dynamically assigned at the moment I set them up; perhaps each machine saw itself as a potential clash, and refused to take the address. So I assigned new addresses, which stuck, and haven't had a single glitch since. Even my swtich turned out to be fine -so happy days.

  • New network cards fixed me up... all is well! [:)]