Vienna Symphonic Library Forum
Forum Statistics

184,838 users have contributed to 42,370 threads and 255,389 posts.

In the past 24 hours, we have 0 new thread(s), 14 new post(s) and 67 new user(s).

  • incoming network connections

    I am now getting this message in Mountain Lion:

    "Do you want the application “Vienna Ensemble Pro Server (64-bit).app” to accept incoming network connections?"

    What should I do? It keeps coming back no matter whether I answer yes or no.

    Thanks!

    Michael


  • Michael,

    I fought this problem for hours, trying various approaches I found online. I had the problem when I first installed VEP 5.0, and somehow fixed it. But when I upgraded to 5.1, the problem was even more persistent.

    I found a solution...the problem is that VEP somehow lost its proper permissions signature. You can verify this by opening a command prompt and typing...

        codesign -vvv "/Applications/Vienna Ensemble Pro/Vienna Ensemble Pro Server.app"

    ...or if you are running the 64-bit version...

        codesign -vvv "/Applications/Vienna Ensemble Pro/Vienna Ensemble Pro Server (64-bit).app"

    ...my response for this was...

        /Applications/Vienna Ensemble Pro/Vienna Ensemble Pro Server (64-bit).app: code or signature modified

    That is a bad answer. It means that something changed and now OSX can't authenticate the App. I tried uninstalling/reinstalling VEP (I think this is what fixed it in 5.0) with no success.

    I found this fix, and it worked perfectly...

        http://silvanolte.com/blog/2011/01/18/do-you-want-the-application-to-accept-incoming-network-connections/

    Basically, you create a new Certificate, then assign that certificate to VEP (overriding the broken Authentication). As a novice UNIX guy, the only bit I tripped up on was the need to use quotes in the command line because the file path had spaces in it. Other than that, the solution worked perfectly for me.

    Hope this works for you!

    Cheers!

    Randy


  • This is great info, Randy. Thanks very much!

    Michael


  • This will be fixed with the next VEPro update.


  • VE Pro still has this problem.  Is there still a plan to fix it.


  • I am now getting the problem again with the new version of VE Pro.

    Michael


  • Is anybody else receiving this request for permission to allow incoming network connections?

    Michael


  • It's been a problem for me on every version of VE Pro.


  • Are there any updates on fixing this problem?

    Thanks

    Michael


  • If you go to System prefs (OSX)/security and privacy/firewall.... what do you see?  I'll bet your firewall is on.  For some reason recently, I went there and noticed my firewall was turned off, so I turned it back on.  All of a sudden VEPro started giving me this message in a popup window.  When I clicked OK to allow the connection and it then worked.  If you turn your firewall off, I bet this message goes away...

    So, my question is - should I be running OSX with firewall off??

    - Greg


  • Thanks for the suggestion, Greg. I do have my firewall on, but VEPro is alreadly listed there as one of the approved applications. 

    Michael


  • Just checked - when I turn my firewall on, and VEPro 64-bit (the one I use) is also listed, I get the same message:  'Do you want the app .... blah, blah, blah.....Deny/Allow'.  When I turn my firewall off, it works without that 'Deny/Allow' popup coming up.  So, this does seem to be a VSL issue then.

    - Greg


  • Thanks for checking that, Greg. 

    I guess I will put up with it until I hear something from the Vienna team. I don't want to run without my firewall on.

    Michael


  • In the lastest update I am still getting this request to allow VEP to accept incoming network connections. Can someone from the VE team please let me know if there is a way to make this stop?

    Thanks.

    Michael


  • I have the same problem with the EyeTV software, they told me to erase everyting and to re-install !!!!!! [:P]


    MacBook Pro M3 MAX 128 GB 8TB - 2 x 48" - 1 x 27" screen --- Logic Pro --- Mir Pro 3D Dolby Atmos --- Most of the VI libs, a few Synch... libs --- Quite a few Kontakt libs --- CS80 fanatic
  • I can confirm the same - no difference from before. 

    - Greg


  • Hi, 

    I asked our developers and they promised to look into it, but they can´t make any promises right now.

    Best,

    Paul


    Paul Kopf Product Manager VSL
  • Thank you, Paul.

    Michael


  • Thanks, Paul.  In the meantime, we're just going to have to click the 'allow' button.   Man, that's a lot of work........... [:'(]

    - Greg


  • IMO the problem is the *firewall for dummies* configuration in the dialog for the OS X firewall (obviously since a few versions).

    usually in a firewall you can select to allow:

    - connections to certain applications

    - connections from certain IPs

    - connections to certain ports

    - or any combination of the above three.

    (the same for outgoing connections)

    i'm sure you can still set all this using terminal, though i could not find any info about this on the net. possibly they have just done too much when fixing this issue http://support.apple.com/kb/HT6011

     

    also apple explicitly mentions that blocking acces to a certain application can prevent regular access to another application http://support.apple.com/kb/PH14191

     

    what a bummer ...


    and remember: only a CRAY can run an endless loop in just three seconds.