Vienna Symphonic Library Forum
Forum Statistics

185,035 users have contributed to 42,375 threads and 255,405 posts.

In the past 24 hours, we have 3 new thread(s), 8 new post(s) and 76 new user(s).

  • Waves plugins

    Hi guys, i wonder if VE PRO5 now supports waves plugins? That will be a good reason to upgrade ...

  • You need to ask the other way round [;)]

    Beat


    - Tips & Tricks while using Samples of VSL.. see at: https://www.beat-kaufmann.com/vitutorials/ - Tutorial "Mixing an Orchestra": https://www.beat-kaufmann.com/mixing-an-orchestra/
  • I take that as no, right? Waves update their plugins to work within VE Pro - donno - besides too expensive for me to replace all mt waves plugins! Hence the original question....

  • last edited
    last edited

    @Electra2662 said:

    I take that as no, right? Waves update their plugins to work within VE Pro - donno - besides too expensive for me to replace all mt waves plugins! Hence the original question....

    Hello my dear.

    On the one hand: Take my answer as nonsense.

    On the other hand: Wave-PlugIns are good and they are worth any cent.

    Nevertheless, when it comes to program updates (64Bit...) I'm not really happy.

    Maybe you understand my "joky" answer which also get a bit of truth - as we can see.

    Beat


    - Tips & Tricks while using Samples of VSL.. see at: https://www.beat-kaufmann.com/vitutorials/ - Tutorial "Mixing an Orchestra": https://www.beat-kaufmann.com/mixing-an-orchestra/
  • This provides a workaround for the Waves VST's in VE Pro: http://hypercube-softwares.dyndns.org/softwares/vstwrapper. The Waves plugins do work fine as AU on OS X by the way.


  • I installed VSTWrapperBuilder on both my desktop and laptop and built wrappers for all of my Waves Plugins(Mercury and SSL Bundle) on both computers. Then loaded a 32-bit Vienna Ensemble Pro instance and moused over "Effect" on the master buss and selected waveshell-VST 8.0.dll -> Any plugin, and as soon as the plugin appeared in the insert slot on the master section, the program crashed, without loading the waves plugin. This happens every time I load a Waves plugin, on either computer within Vienna Ensemble. I'm not sure if I'm missing an important step when I use VSTWrapperBuilder.exe or if it's just buggy. Could you please help me to get my Waves plugins working? Thanks, Ben

  • As for your 64bit comment ... i've upgraded my waves plugins to 64bit, which works fine in the DAW, however VE on the slave still does not want to know or play ball; I'm still running VE4; So, i wonder if there is a decent workaround - no wrapper s/w - that will get my wonderful waves plugins working in VE4 ... or VE5 when i upgrade? Thanks for any help in advance; (Windows 7 x64bit on DAW and slave)

  • I've implemented support for the WaveShell VST on Windows for the next update of VE Pro 5, which should arrive shortly after some testing.


  • A million thank you's -:) When will the update be released?

  • Hi, 

    We will release the new version after successful testing, as Karel said. As soon as possible [:)]

    Thanks for your patience, 

    Paul


    Paul Kopf Product Manager VSL
  • Hi Paul, I am able to load my V9 Waves Mercury Bundle using shell2vst.exe(Windows 7 64-bit) into VEP5, but unfortunately cannot do any automation mapping with them. The "Learn" button does not work with Waves plugins. "Learn" works with any other brand of plugin, however(Free VSTs, Voxengo). You may already be aware of this, but I figured it would be worth mentioning in case you hadn't noticed this problem on on your own systems. Ben

  • The next update of VE Pro 5 will have support for the WaveShell without the need for shell2vst workarounds. I notice that indeed the Learn functionality doesn't work. This basically means that Waves plugins aren't properly sending out the proper events, which would not be surprising considering the amount of non-standard things they're pulling in their plugins. I'll see if I can implement a workaround of sorts (on top of the other workarounds that were required to get WaveShell to work properly in the first place, none of which were required for other plugins).


  • Thanks Karel, that would be most appreciated.

  • What about the support for WaveShell in VE Pro 4?

  • VE Pro 4 will no longer be available as of April 1, 2012, so there will be no new development apart from bugfixes for VE Pro 4.


  • Just to be sure .. can you confirm that Waves 7.1 that have been "un-shelled" using shell2vst.exe and VEPro 4.1.10738 does not work ?