Vienna Symphonic Library Forum
Forum Statistics

186,216 users have contributed to 42,447 threads and 255,773 posts.

In the past 24 hours, we have 2 new thread(s), 11 new post(s) and 29 new user(s).

  • Network issues

    A Cry for help! I have trawled the forums here for help in setting up a Mac Pro Master (on Snow Leopard) to Windows 7 Slave machine. I have tried many different configurations but just cannot get the Server interface to see the slave IP. I have them set static IP's and have followed dru_9310's tutorial to the letter. There is a comment below dru's tutorial saying to change the Mac (Master) MTU to Jumbo 9000. I have tried this also, and even saw the PC (slave) reconfigure the network, so to some degree they are talking but still nothing in the Server Interface. I have also tried entering the slave ip manually but get a connection fail message. Have a deadline and am kinda at my wits end. "Help me Ensemble forum... you are my only hope!"

    1. Do the computers "see" each other for file sharing, etc?
    2. If so, have you turned off the Firewall on both machines?
    DG


  • do you connect connect the slave on the Mac ? if yes see this : http://www.cyrilblanc.fr/site_principal/slave_mac.html

    it is make for 2 x Mac but it should be the same for a Mac and a PC


    MacBook Pro M3 MAX 128 GB 8TB - 2 x 48" - 1 x 27" screen --- Logic Pro --- Mir Pro 3D Dolby Atmos --- Most of the VI libs, a few Synch... libs --- Quite a few Kontakt libs --- CS80 fanatic --- Studio equipped in Dolby Atmos 7.1.2
  • HI DG, Thank you for getting back to me. I am a bit of a network noob, and therefore not sure how to get the machines to file share (done it with 2 macs but never with mac / pc) however, I have turned off the firewalls on both machines. Perhaps my problem lies within that I havent as yet even got them to fileshare?!

  • Hi Guys, Just wanted to show what I have done so far. I have followed these instructions to the letter. Still no love! "SET UP SHARING ON THE PC Click Start, Computer, Local Disk (C:). Right-click, Share With, Advanced Sharing. Click 'Share'. Click Network and Saring Center and set Home or Work and Public profiles as follows: Turn on network discovery Turn on file and printer sharing Turn on sharing so anyone with network access can read and write files in the Public folders Use 128-bit encryption Turn on password protected sharing HOW TO SET UP A GIGABIT LAN (Local Area Network) between a Mac and a PC*. * I have and ASUS P6T ATX motherboard with built-in ethernet running a Realtek PCIe GBE Family Controller driver. If you have a separate ethernet card or a different driver the PC instructions may differ slightly, although the principals will be the same. First, check the ethernet cable! Some Cat5e cables are suitable for Gigabit connections, some aren't - it should have the word 'Gigabit' on the cable if it is. To be certain, spend a little more and get a Cat6 cable, then you'll be sure. I've never had a problem with cables before, but this one tripped me up for a while. If you're only going to use one slave, you only need one cable (regular, not crossover). If you think you may expand to more slaves, get a Gigabit switch (or router, but don't use your cable modem that you also use for wifi - you'll see why later) and an extra cable. The Netgear GS series works (I have the GS108); I have heard that D-Link switches don't always work, but I haven't tried them, so that may not be true. SWITCH OFF WIFI ON BOTH COMPUTERS! This is where I went wrong for a long time - I thought I was connected via LAN but they were actually communicating via wifi. You can switch it back on later, but let's get the LAN working first. Connect the Mac and PC to the Gigabit switch. If you're lucky it will all work. But it probably won't, so... SETTINGS ON THE MAC (credit to Chris White for this) Go to System Preferences, Network, Ethernet 1 (if you have a 2-port machine and assuming you've used port 1): Configure IPv4: Manually IP Address: 169.254.1.2 Subnet Mask: 255.255.255.0 [everything else blank] Click Advanced and then Ethernet: Configure: Manually Speed: 1000baseT Duplex: full-duplex, flow-control MTU: Standard (1500) SETTINGS ON THE PC Click Start, Control Panel, Network and Internet, Network and Sharing Center [sic], Change Adapter Settings (in the left side-bar). Double-click on Local Are Connection - this should bring up the LAN status panel where you can see if you're connected and at what speed (you can also use the Windows Task Manager to monitor this, but you can't change any of the settings there). Ideally you'd see something like this: IPv4 Connectivity: No Internet Access IPv6 Connectivity: No Internet Access Media State: Enabled Duration: [time] Speed: 1.0 Gbps Click on Properties and in the Networking window (which should have just popped up) double-click on Internet Protocol Version 4 (TCP/IPv4) (it's in the list of ticked items). Now we're going to fix the PC's IP address, so the Mac (which we fixed when we set the IPv4 address to manual) will always know where it is. Click 'Use the following IP address': IP address: 169.254.1.3 Subnet Mask: 255.255.255.0 [everything else blank] Click 'OK'. Now you should be back to the previous window (Local Area Connection Properties). Under 'Connect using:' click Configure which will launch the driver panel. Click Advanced, scroll down to (and click) Speed and Duplex and set the value to 1.0 Gbps Full Duplex. You may need to restart everything (and check all the settings have been saved if it doesn't work). Now when you click Start, Control Panel, Network and Internet, Network and Sharing Center you should see your PC connected to an Unidentified Network via the Local Area Connection (in blue). If you click on that, the status box pops up and you should see a connection speed of 1.0 Gbps."

  • last edited
    last edited

    @Cartesian said:

    HI DG, Thank you for getting back to me. I am a bit of a network noob, and therefore not sure how to get the machines to file share (done it with 2 macs but never with mac / pc) however, I have turned off the firewalls on both machines. Perhaps my problem lies within that I havent as yet even got them to fileshare?!
     

    If file sharing doesn't work it is unlikely that your network is set up correctly for VE Pro to work. However, I can' read your loooooooooooong post as there is no structure to it. i lose the will to live by the 3rd line. [:(]

    Please go to Profile/Community/Content Editor on this forum and set it to Enhanced. Then you should be able to re-format your post to make it legible.

    DG


  • Hi DG,

    My apologies for unintelligable postings! Thoroughly appreciate your time pal. Heres what I followed:

    SET UP SHARING ON THE PC

    Click Start, Computer, Local Disk (C:). Right-click, Share With, Advanced Sharing. Click 'Share'. Click Network and Saring Center and set Home or Work and Public profiles as follows:

    Turn on network discovery
    Turn on file and printer sharing
    Turn on sharing so anyone with network access can read and write files in the Public folders
    Use 128-bit encryption
    Turn on password protected sharing 

    HOW TO SET UP A GIGABIT LAN (Local Area Network) between a Mac and a PC*.

    * I have and ASUS P6T ATX motherboard with built-in ethernet running a Realtek PCIe GBE Family Controller driver. If you have a separate ethernet card or a different driver the PC instructions may differ slightly, although the principals will be the same.

    First, check the ethernet cable! Some Cat5e cables are suitable for Gigabit connections, some aren't - it should have the word 'Gigabit' on the cable if it is. To be certain, spend a little more and get a Cat6 cable, then you'll be sure. I've never had a problem with cables before, but this one tripped me up for a while.

    If you're only going to use one slave, you only need one cable (regular, not crossover). If you think you may expand to more slaves, get a Gigabit switch (or router, but don't use your cable modem that you also use for wifi - you'll see why later) and an extra cable. The Netgear GS series works (I have the GS108); I have heard that D-Link switches don't always work, but I haven't tried them, so that may not be true.

    SWITCH OFF WIFI ON BOTH COMPUTERS!

    This is where I went wrong for a long time - I thought I was connected via LAN but they were actually communicating via wifi. You can switch it back on later, but let's get the LAN working first.

    Connect the Mac and PC to the Gigabit switch. If you're lucky it will all work. But it probably won't, so...

    SETTINGS ON THE MAC (credit to Chris White for this)

    Go to System Preferences, Network, Ethernet 1 (if you have a 2-port machine and assuming you've used port 1):

    Configure IPv4: Manually
    IP Address: 169.254.1.2
    Subnet Mask: 255.255.255.0
    [everything else blank]

    Click Advanced and then Ethernet:

    Configure: Manually
    Speed: 1000baseT
    Duplex: full-duplex, flow-control
    MTU: Standard (1500)

    SETTINGS ON THE PC

    Click Start, Control Panel, Network and Internet, Network and Sharing Center [sic], Change Adapter Settings (in the left side-bar). Double-click on Local Are Connection - this should bring up the LAN status panel where you can see if you're connected and at what speed (you can also use the Windows Task Manager to monitor this, but you can't change any of the settings there).

    Ideally you'd see something like this:

    IPv4 Connectivity: No Internet Access
    IPv6 Connectivity: No Internet Access
    Media State: Enabled
    Duration: [time]
    Speed: 1.0 Gbps

    Click on Properties and in the Networking window (which should have just popped up) double-click on Internet Protocol Version 4 (TCP/IPv4) (it's in the list of ticked items).

    Now we're going to fix the PC's IP address, so the Mac (which we fixed when we set the IPv4 address to manual) will always know where it is.

    Click 'Use the following IP address':

    IP address: 169.254.1.3
    Subnet Mask: 255.255.255.0
    [everything else blank]

    Click 'OK'. Now you should be back to the previous window (Local Area Connection Properties). Under 'Connect using:' click Configure which will launch the driver panel. Click Advanced, scroll down to (and click) Speed and Duplex and set the value to 1.0 Gbps Full Duplex.

    You may need to restart everything (and check all the settings have been saved if it doesn't work). Now when you click Start, Control Panel, Network and Internet, Network and Sharing Center you should see your PC connected to an Unidentified Network via the Local Area Connection (in blue). If you click on that, the status box pops up and you should see a connection speed of 1.0 Gbps.

    As an update also, I have been pinging the machines and they are seeing each others IP. I have also done this:

    Goto Start Menu 
    Search for: Local
    Hit Enter
    Select Local Security Policy
    Goto Local Policies> Security Options 
    Double Click on Network security: LAN Manager Authentication 
    Change level to: Send LM # LTLM Responses 

    Then, 

    Goto Network security: Minimum session security for NTLM SSP 
    De-select Require 128-bit encryption 
    Hit OK 


  • Hi Cyril,

    No, I'm using the PC as the slave. I've beening pinging the IP's and all good there. Really stuck!

    Cart.


  • last edited
    last edited

    @Cartesian said:

    Hi Cyril,

    No, I'm using the PC as the slave. I've beening pinging the IP's and all good there. Really stuck!

    Cart.

    Try the way I have done it, the trick is to ask DHCP for an IP adress an to put that as a fixed address

    Good luck


    MacBook Pro M3 MAX 128 GB 8TB - 2 x 48" - 1 x 27" screen --- Logic Pro --- Mir Pro 3D Dolby Atmos --- Most of the VI libs, a few Synch... libs --- Quite a few Kontakt libs --- CS80 fanatic --- Studio equipped in Dolby Atmos 7.1.2