Vienna Symphonic Library Forum
Forum Statistics

181,712 users have contributed to 42,180 threads and 254,557 posts.

In the past 24 hours, we have 1 new thread(s), 12 new post(s) and 51 new user(s).

  • VEP5 and Play

    Hello All,

    I'm scratching my head here...I looked around and could not find the exact issue in a previous thread. I may not have looked around enough but if there is a thread out there I apologize in advance and if you could kindly direct me there it would be appreciated. A little background on my workflow with VEP5....originally I used 4 instances of VEP5 ....strings, woods, brass and percussion. I'm running VEP5 on a single computer not a slave machine. My host DAW is PT10. I had this template set up to load full key switch masters of Play.. 1 instance for each instrument...Woods instance of VEP5 contained 6 instances of play...1 for each instrument...3FLT KS, 3OB KS, etc. VEP5 was set to 1 thread per instance as I'm running on a MacPro Quad core w/ 16g ram. PT10 set to 1 core. This seemed to work perfectly fine.


    So I decided to set up a template running 1 instance of VEP5 and having all instruments and Play instances assigned accordingly via midi....I brought in a full orchestral piece I had written using the previous workflow into the new single instance of VEP5. I started having drop outs...I went back to VEP5 and the instruments (instances of play) that should be firing but weren't and the key switch is loaded and when I drag the mouse over the keyboard in Play you can see the light on my external sample drive blinking as though they are being triggered but there is no audio.


    Now I went and set the voice limit in Play low to 128 and I got the same "dropping out"....so that told me I needed to increase my voices and that was the culprit. So I reloaded the instruments (samples or KS's) that dropped out in Play and increased the voices in Play. It play through fine for one pass. Than all the sudden I started dropping instruments again....when I say dropping instruments I mean that Play is no longed responding or playing the audio though to VEP5. Then I lost the whole template completely. Meaning if you look at VEP5 and the CPU usage it is at 0% ...and midi is also no longer being passed through as well. I am running VEP5 in 64bit mode. I tried different threads and I'm not having any luck. Any thoughts would be greatly appreciated. Maybe I'm asking to much of it. My specs are below:


    Mac Pro Model Identifier: MacPro1,1 Processor Name: Dual-Core Intel Xeon Processor Speed: 2.66 GHz Number Of Processors: 2 Total Number Of Cores: 4 L2 Cache (per processor): 4 MB Memory: 16 GB OSX 10.6.8


    Regards,


    Chris


    Sorry I forgot to add that I'm using EWQLSO Platinum 24bit samples.



  • ****Maybe Solved***

    I may have figured this out. However there may be a couple things going on yet...I have to test this out on some other files. It did seem as though the samples were "sleeping". I would drop the instrument at some point in this particular session....I would go to the instrument instance (Play) and drag the mouse pointer on the keys and the samples, according to the external drive light, where being accessed... but there was no audio coming from play. So that's a little weird. I lost my double basses in this particular piece...as described above...however when it got to the very last note in the piece it would trigger! I went back and no audio when playing the keyboard or using the mouse. So I looked at my midi data...i.e. expression, velocity and the such...the velocity of the note that was playing versus the note before it was the same and when I clicked in the velocity node it didn't trigger the sample.


    So I opened a new session with the template in question and reimported the midi data and before I played anything I went and "engaged" the expression data in PT10. Meaning I brought it up a hair or down....that seems to have solved the issue. So there's something weird going on there...as though PT is not registering the expression data right off the bat? Then it's causing a conflict with VEP5"


    While I was writing this post VEP5 lost all communication and is saying 0% cpu? It was however more stable with the above? I'm going to try a new cable.


  • I'm not sure if you left some information off, but it reads as though you're assigning 'threads' the same for one instance of VEP as for 4. ie., that would seem to be a heavier instance. if you haven't done, assign more threads per instance. if you have PT on the same machine, give VEP 3.

    but, whole dropouts makes me wonder if this is somewhat a coincidence/ are you using a fixed IP or dynamic? A dynamic IP is the first culprit I would want to eliminate, seeing that symptom.


  • the sleeping samples also prompts the question about IP settings.


  • Hey, Thanks for the feedback. Now here's probably a dumb question...when you say fixed IP or dynamic.....where do I control this and If you could give me a brief description of the concept in regards to VEP that would help. When I open the preferences in VEP5 it states "Chris-Clarks-Mac-Pro.local" for the server name....is this what you are referring to. Or are you referring to when I initiate and instance of VEP the address that comes up for the instance? Thanks in advance for the help Civ3.

  • Do I need to set this up in OS X even if VEP is running on that machine? And yes you were correct about this being a heavier instance of VEP. I tried adjusting the thread allocation setting and it didn't seem to make a difference.

  • Hey Civ,


    I think I know what you're talking about....maybe not...but in the preferences for OSX 10.6>Network> I currently have listed:

    Ehternet 1

    Ehternet 2

    Firewire


    Ethernet 1 is connected to an ATT router with the Config IPv4 set to using DHCP. And location is automatic. Now I'm assuming you're not talking about changing that as it's connected to a device.


    Do I need to "create and new service" and if so what would I choose? I'm not sure if this is what you are referring to. Thanks again for the help.


  • "Location = Automatic" is dynamic.

    when you set your IP, 'Location' will read 'Self-Assigned IP'.

    'advanced' tab> Configure IPv4: Manually. IP Address, eg., 169.254.165.0

    there is a thread here that specifies what you *should* use, ie. what would be a problem. I don't remember the details. I know my setup works, and that you can't have two computers with the same address, so a different address for you slave(s) than the master.


  • So I change my IP to static. Loaded the template session in PT....threads set to three. Same issue....plays through once and you can here instruments going in and out....I stop it before it reaches the end of the piece and those voices start to play back fine....get to the end of the piece and then drops out...0% CPU ...meaning no audio and no midi going through to VEP. It's like there a trigger at those notes that's telling it to do something. I don't know. Now maybe I have to create a new template as I changed my IP address. Or do I now have to change the server name to the new IP. Again I'm running on a local machine. Now I do have 3 channels assigned to VEP port 2 midi channels 1,2,3,4. in this template and same instance...instead of creating a separate instance for those extra midi channels. Maybe this is causing a conflict with play....I'll have to go back and see if 2 instrument are firing on the same channel in play...even though VEP and PT seem to accept it.

  • the server will just reflect what the address is automatically. you mentioned a router (which you don't need with 'local host' or unless you need more than one connection off of one port)and I wonder if that's a problem. also be sure that this ethernet is not connected to the internet or anything else. I think an internet address start with 192? Sorry, I'm not that much a geek. I managed to set addresses that work great here.


  • Ok. So I set up a templates 2 instances of VEP putting those other channels on the second instance of VEP. I'm having the same issue...so that's not it. Here's the weird thing...I played the piece through once....Dbl Basses dropped....if I go to the Play instance and look at the double basses everything looks normal only no audio....midi plays through and when I play the instrument my sample drive flickers and Play is registering that voices are being fired? The mb indicator shows this as well as the voices. Bassoons dropped as well same thing. Now...trombones are firing but you can barely hear them. So I just played the piece again after about 10 min and it's like there's volume or expression controller data somewhere getting triggered.. as the trombones just started playing normal. And the bassoons are back on line...double basses however still no sound.


    Now this can be unrelated. I still have no Dbl Basses... as above the memory and voices in Play is still registering...but nothing out of play. I did mess around with the play back engine in PT which is usually set to 512.....I set it to 1024 and it dropped VEP....i.e. VEP showed 0% CPU. I went back to the play back engine reset it to 512 and it came back on line....but still no Dbl Basses. This is leading me to believe maybe I've maxed out the voices in PT or it's getting a volume or expression controller from some other source other than whats written?


    Update. I just brought the written expression controller data in PT for the double basses up a hair and I have Basses now. This is telling me that some how the expression or midi controller data is not resetting or there is a conflict somewhere. I tried this with the trombones when they first went out and it did nothing.


    This however does not explain why at the end of the piece VEP just lets out and we're at 0% CPU. Now in this new template where I have 2 instances of VEP it was only the one instance....the larger of the 2 which has a full 16 channels loaded the dropped. When you go to VEP it's as though Play is frozen where it went out...volume bars are frozen and memory indicators to. Also no midi is being received by this instance of VEP. The other of instance which has percussion and tuba, etc....plays fine and midi is going through via PT....and when I look at the instance that's disconnected and play the instance thats still connect you can see the Play instance registering CPU usage. At any Rate at this point I have to force quit both PT and VEP.


    I'm going to reopen the session and delete all controlled data and see how it plays through.


    So I reloaded the template and test out the expression data controller again on the double basses. I moved it up hair....but it doesn't play the basses right away I have to play the piece from the beginning and then it's on line. If I play the piece anywhere past the last notes it drops. It's like there a controller telling it to purge or something.


    So I went back to the original source session....which I did not use VEP. I had several instances of play in pro tools.....equal to the template in VEP. I'm experiencing the same weird issues.....voices going in and out....weird responses to expression data. Back to the drawing board?


  • Thanks for the help Civ. I'm thinking this is not a VEP issue and is isolated to a few sessions. However, I was orchestrating something that was sent to me via a midi reduction and was having some of the same issues. So I'll have to tinker with it some more. I think it may have to do with A) corrupt midi data, if there is such a thing B) processing and core parking....Thanks for the help. Are you using PT?