Vienna Symphonic Library Forum
Forum Statistics

181,614 users have contributed to 42,178 threads and 254,543 posts.

In the past 24 hours, we have 3 new thread(s), 11 new post(s) and 37 new user(s).

  • Velocity Max and PLAY

    I'm having an interesting problem with VePRO and Play. I'm used to limiting my velocity with the PLAY instruments by adjusting the Velocity Max field so I only play soft notes of the piano for example no matter how hard I play. Right now with Play in VePRO when I decrease the velocity max from 127, it won't play anything when velocities exceed that amount. So, if I put the velocity max to 80 and play a velocity of 120, I don't hear anything. What I'm used to with PLAY standalone is if I play 120 velocity, it will play the maximum velocity (this being 80). I like to use the velocity max to limit the samples used but right now, it isn't working that way. Anyone else having this problem?

  • This is totally up to the Play plugin. We simply deliver the midi message to it, what then happens is beyond our control.


  •  I find that Play reacts exactly the same as a stand alone or in VE Pro, I find that if you limit the velocity Max, then velocities above this are ignored and nothing sounds.

    Are you sure that Play stand alone really sounds above it's velocity max setting? because it certainly doesn't here, and it is not supposed to, as it is supposed to be there to allow velocity cross switching between layers.


  • I shouldn't have said "standalone". I actually meant running inside logic which I know isn't standalone. In Logic, If I limit the max velocity inside the PLAY interface (on QL Pianos for example) I hear a sound anytime I play a note. If I play a note higher then the max velocity, I still hear a note, but instead of playing the sample for say a velocity of 127 (which is what I hit the key at), it plays the sample for velocity 80 (which is the max). It sounds like I'll need to look around a bit inside VePro. PLAY is functioning differently inside VePro then it is inside Logic. I want it to function the same for both.

  •  I tried running Play as a VST plug within Cubase, and it still reacts the same, are you actually setting the velocity max in the Play window, or are you limiting the velocity in the Logic track?  Cubase allows a velocity limit per track, and that does give the required effect that you are looking for (everything above say 80 becomes 80), but that is a Cubase function, nothing to do with Play or VE Pro, so it works using Play as a plug in or VE Pro as a plug in. I am sure Logic has a similar function.

    I am running Cubase on a PC, so maybe someone else with Logic on a Mac could test this, in case it is an odd mac/logic bug.