Vienna Symphonic Library Forum
Forum Statistics

183,562 users have contributed to 42,308 threads and 255,100 posts.

In the past 24 hours, we have 5 new thread(s), 11 new post(s) and 59 new user(s).

  • Vienna MIR uses huge CPU?

    Hi There

    I use the orchestral strings bundle and special edition woodwinds with Vienna Ensemble Pro.

    For better result I intend to buy the Vienna MIR and I wonder if my PC system is good enough.

    I have the  HP 8600 workstation, windows 7, 64 bit ,RAM 24 GB, Quad core Intel Xeon E5440  2.83 GHz  2.83GHz. Audio card  ASIO MOTU PCI 2408.

    For this reason I tried the Vienna MIR SE 1.3  trial, but I noticed that the CPU usage reaches the 100% and it seems to me abnormal.

    I use a second PC for the Cubace project via MIDI interface so that the first one works without any other CPU usage.

    I wonder if my system needs more processor or something else goes wrong.

    Is there anybody who could help me pls?


  • Thanks for your interest in Vienna MIR, Yorgos.

    Depending on the system and its settings, it's absolutely normal to see MIR maxing out the CPU. Remember, you're working with some hundreds of convolutions being computed in real-time (... when did you open 100 AltiVerbs or Waves IR-1s the last teime ...? ;-) ...)

    In case you missed the section in the manual: There are quite a few dedicated suggestions what to do when hitting the ceiling. E.g.: Try higher audio system latency (256 samples is a realistic starting point, bigger arrangements might need 1024 and more); use additional processing buffers (available in MIR's Preferences); use less instruments (MIR puts additional strain on the CPU with each instrument. ... and so on.

    That said, it might be possible that you experience problems with the drivers of your audio system. MOTU drivers are not known for their brilliant performance under Windows.

    ... i will ask our IT-specialists to chime in, too, to tell you the In's and Out's of the CPU you're using right now.

    Kind regards,


    /Dietz - Vienna Symphonic Library
  • Thanks for your fast reply

    I actually feel not alone!!!

    I'm in process to do all that you ordered me and also waitting your special advice.

    Best regards


  • You're welcome!

    BTW - the manual is available here: -> [URL]http://www.vsl.co.at/en/68/428/709/376/239.htm[/URL]

    You will find hints on system optimization from p. 85 onwards.

    HTH,


    /Dietz - Vienna Symphonic Library
  • two possible reasons come into my mind:

    - you don't have enabled HT (HyperThreading) in your BIOS i.e. you see *only* 4 cores in your taskmanager instead of 8, so the calculation units cannot be filled fast enough,

    - there is a midi-loop hidden somewhere in your setup (some midi-input is connected to some midi-output - some cubase versions have by default set *listen to all midi-ins* as midi-source on each track ...)


    and remember: only a CRAY can run an endless loop in just three seconds.