Vienna Symphonic Library Forum
Forum Statistics

184,511 users have contributed to 42,365 threads and 255,341 posts.

In the past 24 hours, we have 0 new thread(s), 9 new post(s) and 66 new user(s).

  • HELP! Vienna Ensemble Service keeps asking me for a "proper license"

    Hello again

    I'm having trouble running Vienna Ensemble with a single key on a slave. It is my understanding that this is possible, but every time I try to start up vienna ensemble service on my main DAW computer without the vienna key, it wont open saying "A proper license cannot be found" and will not start. Even if I then plug in my key, it STILL will not start, citing the above. I have to restart the computer and plug in the key in order to start up ensemble service on my main DAW, and then unplug it and plug it into my Slave to start up the other ensemble service. Once I do this everything works fine, but what a PITA to have to go through EVERY time I want to use Vienna Ensemble.

    I've tried removing all paths from both directory managers (why are there two; one for VI and one for VE?) but this has no effect. Please someone, tell me what I'm doing wrong?! I'd love to be able to use Vienna Ensemble with a single key on a single slave, which really should be possible. Thanks!

  • Can you provide more details of your setup? Which OS's? Which sequencer? I assume you're using VE3?


  • Sorry about that. I'm running VE3 (installed all updates yesterday) on a Dual 2.5GHZ PPC G5 w 7GB Ram OS 10.4.11. My sequencer is Logic 8.02, but this doesn't play a roll, as I'm attempting to open up VE Service before opening my daw, per the manual. Thank you for your reply.

  • do you by chance try to run the service on your sequncer (which obviously has no key and so no license attached)?

    the VE3 license needs to reside on the computer you like to see the GUI .... inserting an instance of VE3 into your sequencer and connecting to a slave (which of course needs to have the service running) does not need a license

    hth, christian

    and remember: only a CRAY can run an endless loop in just three seconds.
  • Hello CM,

    Yes I'm trying to run Vienna ensemble service (the service program, not vienna ensemble program) on my master computer in order to run Vienna Ensemble on my slave, per the manual. The slave is the only computer I want to see the Vienna Ensemble GUI, and of course it has the only key plugged into it. But for some reason Vienna service on my master is asking for a "proper license," and once I get this error, I have to restart my computer, plug in the key and launch VE service again. THEN I can unplug the key, plug into my slave and run VE Service, launch my daw, connect to my slave via vienna ensemble, and go. But its a major drag to have to plug the key into my master to launch VE Service, then unplug the key and plug back into the slave to run VE service on the slave.

    There has to be something wrong, as I'm not running VE on my master daw at all, but yet its looking for the license! I've unloaded all VI from both browsers; I've tried opening VE service on the slave first before the master; I've tried repairing my permissions, restarting the computer multiple times, and STILL it keeps asking for a license on my master when opening VE Service.

    Any ideas whats going on? It seems wrong to ask for a license on the master computer, as I do not see the need to run VE on my master. VE's purpose IMO is to allow other computers to share the processing load, so it would really be a drag if I had to use one of my licenses just to open VE service (NOT VE GUI) on my master.

    Thanks again for your help! Its much appreciated!

    P.S. Obviously before I had VE I ran all my Vienna VI's on my master. Could this in anyway be the cause of my problem? I did unload all the libs from the VI directory manager as well, but it didn't make a difference.

  • that's the misunderstanding (please double check the manual and video)

    - the VE3 service runs on the SLAVE (here are the vienna instruments libraries, the ViennaKey, the GUI)

    - the VE3 plugin is inserted on the MASTER (=sequencer) and gives you only a *connect to host* window

    - in this dialog you select your slave computer (by name or IP address) and now the GUI opens on the SLAVE


    advanced setup: you _could_ run an additional service on the MASTER too (now you need the license and key on the MASTER), but you will still insert the plugin into the sequencer and in this case connect to the *localhost* (GUI opens on MASTER)


    hope this clears it up, christian

    and remember: only a CRAY can run an endless loop in just three seconds.
  • ok, think I figured it out. You dont need to run VE Service on the master! I tried running VE Service on just the slave and it works fine! I guess I misunderstood the manual. Glad it works! YIPPY! edit: I see you came to the same answer CM! Thanks for your help!!

  •  Jon,

    How do you run the

  • last edited
    last edited

    @jjim1 said:

     Jon, how do you run the 
     ... service?


     on a mac you'll find it in Applications accordingly ...


    what caught my attention though is, that you registered one VE PRO only so far so maybe you don't have the license on the respective computer (the license needs to reside on the computer you want to open the VE PRO interface - the connection dialog on your host computer does not need a license)

    hth, christian

    and remember: only a CRAY can run an endless loop in just three seconds.