Vienna Symphonic Library Forum
Forum Statistics

181,823 users have contributed to 42,187 threads and 254,605 posts.

In the past 24 hours, we have 4 new thread(s), 26 new post(s) and 48 new user(s).

  • when will VE be 64 bit on mac

    Kontakt 3.5 is 64 bit I see no reason why VE shouldn't be 64 bit on Mac (i.e. no realistic memory limits). Maybe I missed a memo though.


  • I think it's the same reason why Adobe Photoshop has announced a 64 Bit version exclusively for Windows.

    Both applictaion are based on the same framework: QT by TrollTech.

    When a 64 bit QT version for OSX is released we'll be able to offer the 64 Bit OSX version.

    So hopefully soon.

    I don't know on which framwork Kontakt is based, but propably not on QT.

    And as far as I know, Kontakt 3.5 is announced but not released.

    best

    Herb


  •  according to what I've read it's NOT exlusive to windows it's claiming 64 bit mac support which was got me wondering.  Thanks for the reply. 


  • KOntakt 3.5 is coming out in December and is 64bit!!!! If they come out BEFORE VI 64bit...I am going to be severely pissed off... SvK

  • last edited
    last edited

    @svonkampen said:

    KOntakt 3.5 is coming out in December and is 64bit!!!! If they come out BEFORE VI 64bit...I am going to be severely pissed off... SvK

    Not to split hairs, but the December release is a public beta, not a proper release. If it happens. If it works...!

    The other thing to remember, is that it may well be that there won't be a 64bit version of the plugin, as there are currently no 64bit sequencers for OSX.

    DG


  • DG..... You run it stand-alone....not plug-in SvK

  • last edited
    last edited

    @svonkampen said:

    DG..... You run it stand-alone....not plug-in SvK

    OK, so why do you need an OSX version, when you can run bootcamp?

    DG


  • last edited
    last edited

    @DG said:

    OK, so why do you need an OSX version, when you can run bootcamp?
    OMG, why do we buy mac's ? Because of OSX!

  • last edited
    last edited

    @DG said:

    OK, so why do you need an OSX version, when you can run bootcamp?
    OMG, why do we buy mac's ? Because of OSX!

    However, if you are running a standalone slave, it doesn't really matter what OS you are running, and it just happens that XP is a better OS for streaming samples. If you are running it on the same computer as your sequencer, then yes, you need an OSX version.

    Don't let OS religion get in the way of performance issues....!

    DG

  •  this all not the point, the point is mac is (seemingly) capable and there seems no reason for it to be 64 bit since other software companies managed to do it (supposedly). that's my point - I don't care which one you enjoy using.  I happen to have both and would like to run my VE my mac because it will work better in my particular setup.   


  • last edited
    last edited

    @DG said:

    it just happens that XP is a better OS for streaming samples
    I don't believe you.

  • last edited
    last edited

    @DG said:

    it just happens that XP is a better OS for streaming samples
    I don't believe you.

    Up to you what you believe.

    DG


  • DG.... no....as I run Logic 8....so VI OSX64 would run standalone.....and get piped into Logic8 via sound-flower. SvK

  • last edited
    last edited

    @svonkampen said:

    DG.... no....as I run Logic 8....so VI OSX64 would run standalone.....and get piped into Logic8 via sound-flower. SvK

    Ah yes, then you need either 64bit Logic, and/or 64bit VE. In your opinion, do you think that this will be significantly better than using multiple standalones?

    FWIW, when 64bit VE is available, you won't need to run it as a standalone to access all your RAM.


    DG

  • the esx sampler of logic can address more than 4 GB RAM. So it's possible on os x ! http://support.apple.com/kb/HT1041

  • last edited
    last edited

    @kurt said:

    the esx sampler of logic can address more than 4 GB RAM. So it's possible on os x !

    http://support.apple.com/kb/HT1041

    Not with a cross-platform app such as VE. AFAIK the EXS player uses X-Code, which can't be used for cross-platform apps.

    DG

  • The cruel joke is that the VSL Performance Tool doesn't work in Logic 8, which is the one with big memory access, in fact the only really big EXS library I know of is the original VSL. (Not that I'm blaming VSL for this, just pointing it out.)

    But you can use multiple stand-alone VE3s on a Mac and access lots of RAM that way. It works very well.

  • last edited
    last edited

    @kurt said:

    the esx sampler of logic can address more than 4 GB RAM. So it's possible on os x !

    http://support.apple.com/kb/HT1041

    Not with a cross-platform app such as VE. AFAIK the EXS player uses X-Code, which can't be used for cross-platform apps.

    So the VE is written in a different code than the kontakt engine ?

  • last edited
    last edited

    @kurt said:

    the esx sampler of logic can address more than 4 GB RAM. So it's possible on os x !

    http://support.apple.com/kb/HT1041

    Not with a cross-platform app such as VE. AFAIK the EXS player uses X-Code, which can't be used for cross-platform apps.

    So the VE is written in a different code than the kontakt engine ?

    I can't answer that, because I haven't seen Kontakt 64bit. However as all other developers have been complaining that a vital bit of code needed for the OSX 64bit versions of their software wasn't released when Leopard was (and still may not have been, for all I know), it seems likely that Kontakt is not using this bit of code. See Herb's answer at the top of this thread.

    DG

  • Oops, i didn't saw the answer of Herb.

    Good news about QT 4.5 :
    Futureproof Qt users’ investments on the Mac® platform with added 64-bit support Continuing the Qt tradition of insulating developers from platform-specific changes, Qt 4.5 adds support for developing 64-bit applications on top of the new Mac Cocoa API, making it possible for Qt developers to deploy resource-intensive applications to the latest version of the Mac OS (10.5).

    http://trolltech.com/about/news/qt-4.5-tech-preview-released