Vienna Symphonic Library Forum
Forum Statistics

181,827 users have contributed to 42,187 threads and 254,606 posts.

In the past 24 hours, we have 4 new thread(s), 27 new post(s) and 46 new user(s).

  • Really slow load time for VIenna Instruments

    I have purchased Vienna SE Standard and Extended libs, plus various download libs like Brass PLUS, Woodwinds PLUS and Srings PLUS as well as Appassionata Strings and most recently Epic Horns PLUS and Fanfare Trumpets. I noticed that the load time for either stand alone or in Logic 8/DP6/Cakewalk Sonar 7 (on PC) is very slow. Moreso on the Mac than PC. I have a 2.66 GHZ Mac Pro and for some reason it's very slow in loading the licenses. Sometimes it actually hangs up. Is anyone else having these problems?

  • To have fast loading time you need to put your libs on a raid 0
    More disk you have on your Raid 0 faster it will be
    My raid 0 has 6 disk of 36 GB 10 000 rpm (DW raptors)
    Best Cyril

    MacBook Pro M3 MAX 128 GB 8TB - 2 x 48" screen --- Logic Pro --- Mir Pro 3D --- Most of the VI libs, a few Synch... libs --- Quite a few Kontakt libs --- CS80 fanatic
  • Hi David, how long is 'very slow'? If you're talking about instrument load time (as opposed to opening the VI) could you give an example? You can get reasonable load speeds without using RAID, but since VSL instruments use exceptionally large numbers of samples it usually takes a while to load them.


  • Hey there. I was actually referring to when you first launch the VI PLAYER. It can take up to a minute or longer to launch that first player. It's like it is searching for all of the libraries and licenses. Once that first player is up and running, subsequent ones load in a couple seconds. Do you think it's the scanning of the licenses that slows this down? I have temp licenses on my syncrosoft key for ALL of the libraries so perhaps it's that. Christian was kind enough to send me that when I got my Appassionata Strings library but did not have the temp license because I have a Steinberg key.

  • last edited
    last edited

    @Fiery Angel said:

    It can take up to a minute or longer to launch that first player.
    In my experience that's normal. I don't know whether it's because it's searching for licenses, but I've got used to it now - I just do something else while it loads! It's the same with Vienna Ensemble.


  • Hi,

    yes, that´s the scanning process of the licenses. All possible licenses (and we have more than 100 by now, with the Download Products) are scanned and compared with the sample data available.

    This only happens ONCE - with the initial start of Vienna Instruments / Vienna Ensemble. So it makes sense to start the VI / VE right aways when you get into your studio, even before switching on the coffee machine.

    Best,

    Paul 


    Paul Kopf Product Manager VSL
  • Hi Paul,
    May be you could improve the system to have :
    - an "Add a licence" when you install a new product and that will put into a file so at start yo check the vienna key and it's file
    - a rescan "licenses"


    So at start it does not take ages !

    Best

    Cyril
    P.S. can you do something so when you are with Safari you can use the HTML editor

    MacBook Pro M3 MAX 128 GB 8TB - 2 x 48" screen --- Logic Pro --- Mir Pro 3D --- Most of the VI libs, a few Synch... libs --- Quite a few Kontakt libs --- CS80 fanatic
  • Sorry to bump this one, but having just installed the latest VE and VI I'm finding that the time it takes to scan the licences is ridiculous - and sometimes when launching VE3 server it hangs completely- can we not change the scanning mechanism so it only scans the licences that are required for the files loaded in directory manager?

    TIA

    Tim

  • Yea this is the very weakest part of VI and VE in my opinion - When I load digital performer it has to do this scanning every time i start a new project or move to a different one. The same of course when working in any program that accesses VI/VE as AU or VST. Its just WAY TOO LONG for not even loading sounds. It occasionally hangs also and as a result causes the parent program to hang as well.

    Now if I open the Syncrosoft license program I see all licenses within 2 or 3 seconds, why does VSL take 2 or 3 minutes instead? This really eats my energy and cuts down on creativity time which is the most precious commodity in my studio.

    I came to the forum hoping there might be someone talking about it or some solution I can do to speed it up. Let me spend time loading great sounds, not loading the player :P


  • last edited
    last edited

     

    @chris_3594 said:

    I came to the forum hoping there might be someone talking about it or some solution I can do to speed it up. Let me spend time loading great sounds, not loading the player 😛

    There is a solution. However, you wouldn't be interested in hearing it. [;)]

    DG


  • chris, this catched my attention ... 3 minutes for 4 licenses? there must be something else going on, this is definately too long. you're on a mac - right? try rebooting and repair permissions on your system volume using disk utility.

    a newer version of VI/VE has been released today - maybe it will fix your issue (update only after rebooting, run permission repair after doing so again ..)

     

    something what sounds a little bit esoteric but could possibly help:

    - open your host, insert a VI or VE

    - close your host (no need to save the *arrangement*)

    - launch process monitor

    - kill vslserver (if running), kill vsldaemon

    - now the synsopos process should disappear without killing it

    - next launch of your host and inserting VI/VE should be noticably faster

     

    does that improve something? christian


    and remember: only a CRAY can run an endless loop in just three seconds.
  • I am with you 100%. This should be changed. Scanning licenses is a legal thing and shouldn't bother the (legitimate) user.