Vienna Symphonic Library Forum
Forum Statistics

185,254 users have contributed to 42,389 threads and 255,469 posts.

In the past 24 hours, we have 3 new thread(s), 19 new post(s) and 45 new user(s).

  • Annoying stutter sounds on STOP in Sonar

    Hi
    If I have a project playing in Sonar and hit the stop button - the sound
    does'nt just stop - it brakes in a fast stutter sound of about 2 sec.
    This only happends when VSL VI's are involved and only if there are notes
    active at the time of stopping. This also happends when Sonar automatically stops at the end of a piece.

    Anybody else experience this with Sonar or other seqs.?
    Any ideas why?

    It were annoying when you editing a section and have to make a lot of stops - its a pretty nasty sound.

  • possibly unrelated, but IMO an interesting observation: we added lately an mpeg2 video-card (matrox X.100) to a cubase3 system, which also showed such a behaviour and suddenly the stutter disappeared. no clue why in detail though.
    christian

    and remember: only a CRAY can run an endless loop in just three seconds.
  • Did the stutter appeer for other plug-ins as well?
    My problem only relates to when VSL VI's are present in a project all other plug-ins works fine.

  • ahem - unfortunately we don't use other plugins [6] so i can't comment, also this effect does not show up on other machines.
    christian

    and remember: only a CRAY can run an endless loop in just three seconds.
  • last edited
    last edited

    @cm said:

    ahem - unfortunately we don't use other plugins [6] so i can't comment, also this effect does not show up on other machines.
    christian


    Not even in a completely non-competitive area, like a tiny little Rock drumset or an electric bass? [[:|]] [[;)]]

    well - I need to establish the error source so:
    It is apparently an issue with the VI, as I don't get it with other plugs - but
    obviously it only occures in a combination with....?

    Can anyone confirm/deny similar problems with Sonar/VI combination?
    I use Sonar6 producer - but as I remenber it was present in Sonar5 too.

  • Hi. As you, I only use VI plugin on Sonar 6 Producer. I just began using Sonar simply to use VST format instead of stand alone player to support multiple simultaneous tracks during composition. (Used to be a VSL Giga box) I sometimes get the 'stutter' you mention, and I also get such a long delay between playing the MIDI controller and hearing the sound as to make the setup unusable. I have spoken with others who know Sonar well but do not have VI and have not had similar issues with other VST plugins.

  • Hi guys,

    Well, I am now experiencing the stutter you mentioned.

    Have sonar 6 producer on a P4 3ghz PC with 1.5gb ram, winxp pro.

    Have VI cube with App Strings which is what I am using as I experience
    this stutter issue.

    I have been up for a while and need to go to sleep but when I
    get back to my computer tomorrow I will try other VSTi's and see
    if the same thing occurs.

    I'll let you know what I find.

    Just wanted to let you guys know that you are not alone.

    David

  • I get the stutter sometimes with Cubase, and I'm pretty sure it's the graphics card which causes that behaviour. It's a rather "old" Matrox Millennium G 550 which has to handle two displays, and I think it's simply too slow, or its RAM management leaves something to be desired ... Was worse with GigaStudio, though. Of course, the speed of the harddisk your samples are stored on may also have an effect.

    Cheers,
    David
    VSL manuals

  • I use Sonar 6 Producer and do NOT experience any stutter with VSL VI. However, I do currently seem to have a memory leak. Over several hours of use my system slows down more and more until Sonar stops working altogether. Anyone experience this?

    --Jay

  • Hi JBacal,

    What is video card you are using?

    David

  • nothing fancy-- Radeon x300 graphics card-- 128 MB.

    Best,
    Jay

  • OK I checked about a dozen of my other VSTis and none of them make Sonar stutter.

    It only happens when the VSL VI is loaded.

    I have the 6.2 upgrade of sonar and will install it now to is if there is any change.

    Keep you informed.

    David

  • Hi David
    txh for keeping this one alive.
    looking forward to hear about the 6.2 installation.
    ( I will install it too in the near future- but right now I'm hung up )

  • Does Sonar seem generally sluggish when you hear the stuttering? When you draw controller data do you get as many points as you would expect? How much memory are you using? Do you get this problem even with very simple (small memory) VSL patches? Or only when you are maxing out your system? Does it happen at the beginning of sessions or after using Sonar for a while?

    Thanks,
    Jay

  • Hi JBacal,

    Sonar is not sluggish at all when the stutttering occurs, or just in general. It performs fine and with no issues.

    I have not noticed any issues with drawing controller data, though I did
    not specifically look into that.

    I get the stutter even if only 1 VSL VI is initiated with a single patched loaded
    and nothing else loaded in Sonar. I get the stutter even when the VSL VI is the only VSTi loaded. So, its not a system, CPU, or RAM overload issue.

    It happens only when a VSL VI midi track is playing and I hit stop.
    When I hit stop the stutter occurs. If the VSL track(s) have come to an end but there is matierial on other non-VSL tracks and I let them play and then hit stop then there is no stutter.

    I have experienced this with the VI's interface open and closed.

    If you think its video card I can pull one off of an older computer and see if there is more or less stutter.

    BTW, the Sonar 6.2 upgrade did not make any difference in the stutter issue.

    David

  • I've seen this stutter on stop when using the ASIO drivers in Sonar, but never with WDM. Maybe want to check your driver setting and see if that helps.

    Steven

  • Hi sgentry,

    Thanks for the input.

    I was under the impression that WDM was not the best driver to use
    in Sonar so I have been using the ASIO driver.

    I'll try the WDM tonight and report on that.

    I think that WDM has more latency, if so I will deal with the
    stutter and not sacrifice latency.

    If it is a WDM - ASIO thing why does it only happen with the VSL VI?

    David

  • last edited
    last edited

    @David Mikautadze said:

    Hi JBacal,

    Sonar is not sluggish at all when the stutttering occurs, or just in general. It performs fine and with no issues.

    I have not noticed any issues with drawing controller data, though I did
    not specifically look into that.

    I get the stutter even if only 1 VSL VI is initiated with a single patched loaded
    and nothing else loaded in Sonar. I get the stutter even when the VSL VI is the only VSTi loaded. So, its not a system, CPU, or RAM overload issue.

    It happens only when a VSL VI midi track is playing and I hit stop.
    When I hit stop the stutter occurs. If the VSL track(s) have come to an end but there is matierial on other non-VSL tracks and I let them play and then hit stop then there is no stutter.

    I have experienced this with the VI's interface open and closed.

    If you think its video card I can pull one off of an older computer and see if there is more or less stutter.

    BTW, the Sonar 6.2 upgrade did not make any difference in the stutter issue.

    David



    Same experiences here - does'nt make any difference if its one or more instances, only more instances seems to make more noise.
    I'm positive that this is not a performance issue.

  • Ok, I tried the WDM drivers and the stutter is gone!

    There is now a single click/pop noise on Stop but the stutter
    is no longer present and the single click/pop is more bearable.

    Surprisingly, I have not experienced any increase in
    latency or any negative issues from the use of WDM drivers, as of yet.

    Thanks to sgentry for the tip!!!

    Sapkiller, can you try WDM drivers as well to confirm that ASIO is the culprit?

    Thanks,
    David

  • David, glad to hear that may have fixed your stutter problem.

    Steven