Vienna Symphonic Library Forum
Forum Statistics

178,856 users have contributed to 42,064 threads and 253,923 posts.

In the past 24 hours, we have 3 new thread(s), 7 new post(s) and 56 new user(s).

  • Extremely high CPU-usage with Synchron Player for iLok

    Hello

    during the weekend I made the switch iLok , redownloaded all my librarys, deleted all prior versions of the Synchron Player (Piano and the normal one) and installed everything again. So far, everything is running fine except one rather important thing: the CPU-usage is skyrocketing through the roof even when playing only one single voice (for example when playing the new "Hello" instrument, that nice flute). I changed nothing regarding the hardware, my system has the following specs:

    AMD Ryzen 7 3700X 8-Core Processor 3.60 GHz
    32.0 GB RAM @ 3200 MHz
    Gigabyte x570 Board
    Focusrite Scarlett 2i4 2gen interface (48k @ 256 Latency, since 128 is simply unplayable at the moment)
    Windows 11 - 64bit
    All drivers are up-to-date. 

    Any ideas what could cause this behavior? As much as I would like the transition to iLok, this situation is not so great ... 

    Thanks in advance and greetings from Switzerland

    Michael

    Edit for clarification: Playing one single note (!) of e.g. the flute at a buffer size of 128 uses about 90% of the CPU (!). 


  • Hi. Yes, I have the same problem.

    Synchron Pianos seems to play about 200 voices using only 1/4 of the load in Cubase, but Synchron Player takes a huge lot of CPU in some cases, like with the new Fujara flute. A single note of it takes almost the all the CPU bar (a full core), and Smart Orchestra has become completely unusable for me, where I could play many instances before on the same system on the eLicenser version.

    My specs are Intel i9 9900kf and 48gb RAM.

    Cheers,

    Alberto


  • Same issue on a Mac. MBP M1 Max 64 GB Monterey, Logic Pro latest version

    Thé same pièces which had no issues at all before now regularly give system overload when you first playback and instruments play their first notes, a workaround is to go back ton the start of the piece and playback again till the next overload. After all instruments have played their first notes, you can play the pieces from start to finish without issues and navigate back and forth. 


  • I will try the same piece in Cubase. It is a bit tiresome as I have to set up the instrument rack for 10 instruments and add the expression maps to each track to make it perform in a similar way using the key switches provided by the midi export from Logic which sometimes is a bit buggy.

    in Logic I managed to improve the situation a bit by setting the number of threads and cores used to the maximum instead of automatic. No more overloads but sometimes instruments still kick-in only after 2-3 notes when played back the first time. What I noticed is that the system  activity monitor independent from the DAW actually does not show high CPU usage, the peaks are just shown in the Logic internal activity monitor. 

    Question is of course if this have anything to do with the switch to iLok or is it the latest Synchron player update which under the hood had some significant changes. 


  • I tested in both Cubase and Dorico. Cubase, with its usual illogic, none intuitive way of working  ignores the articulation keyswitch midi notes when you have the official VSL expression maps linked to the tracks. So you have to remove them from the track to make them work. As in Logic there is an audio performance peak when a VSL instrument kicks in which causes some clicks. After one playback this does not occur anymore.

    Dorico works perfectly with the keyswitches but also has some clicks when a VSL Synchron instrument kicks in. You always have to run a piece till all instruments have played a few notes to eliminate the clicks.

    I played also with the Synchron player settings Force enable all slots or Force disable all slots. There is no effect on the peaks. Force enable does improve that first notes when an instrument kicks in sound which also is an issue I only have with Synchron libraries.

    By the way I have 4096 samples preload and 4 steaming and loading threads in the settings. Maybe that should be changed to solve this issue. The 100% peak shows only on one high performance cores/threads in Logic.


  • last edited
    last edited

    @Mavros said:

    Question is of course if this have anything to do with the switch to iLok or is it the latest Synchron player update which under the hood had some significant changes. 

    Yes, that is indeed the question. I didn't find a workaround until now. The Synchron Player is not usable for me at the moment. Gladly I've been on vacancies with my familiy during the last week. Any other news on this issue? 


  • Hi, 

    We are currently investigating if that could be connected to processing a lot of MIDI CC data.

    Did you send in some of your projects to support@vsl.co.at yet? The smaller, the better, so we can reproduce this and then take it from there. 

    Best, 
    Paul


    Paul Kopf Product Manager VSL
  • Hi Paul

    in my case, the problem occurs even when I use simply the standalone application. Even when I click a key on the keyboard onscreen with my mouse (!) I can reproduce this. I think this is a strong case against the MIDI CC-theory. 

    Strangely, not all libraries seem to be affected. For example, the Big Bang Library works like it should, Synchron FX Strings and Synchronized Dimension Strings however are heavily affected. The free flute is the worst of all.  

    I am happy to help in your investigation, I am just a little short of spare time the coming days, sorry. (Wife has to do night shifts in the hospital and I have the kids around ... )

    Best wishes

    Michael


  • Same here with a new MB Pro 14 M1 Pro.

    It also crashes Studio One and makes the computer restart. Both running natively (AU) or under Rosetta (VST3)


  • Same here with a new MB Pro 14 M1 Pro.

    It also crashes Studio One and makes the computer restart. Both running natively (AU) or under Rosetta (VST3)


  • Hi,

    I have the same problem. Has it been fixed?

    Thanks


  • last edited
    last edited

    @Paul said:

    Hi, 

    We are currently investigating if that could be connected to processing a lot of MIDI CC data.

    Did you send in some of your projects to support@vsl.co.at yet? The smaller, the better, so we can reproduce this and then take it from there. 

    Best, 
    Paul

    Hi,
    I'm new to VSL super professional libraries and because of sound quality I'm super happy.
    But I'm scared of Synchron Player's huge CPU power consumption that I noticed.
    I hope this can be fixed.
    Best
     
    Lauro
     

  • Hi guys, same problem here!
    The loaded instances take 45-50% of cpu only on idle.
    Any news about this?

    Thanks


  • Hi all,

    I also have big problems with the synchronous pianos, impossible to use the different microphones as I should normally be able to do. I use the Vienna Ensemble. I have a very powerful PC since it is also used for gaming, and I have no problem with games: AMD Ryzen 9 5900x / 64GB Ram. I have already made the settings proposed in other posts to improve things, but as soon as I put 4 or 5 microphones, the CPU is overloaded. There are major optimization issues.


  • I am having the same issue.  I am using the Synchron Harp, Strings Pro and Oboe d'Amour on a pretty large project.  ALL of my other AUs are playing fine and without any issues except for the Synchron Strings Pro.  It is bogging down the system badly and it's so frustrating.  Since switching over to iLok this has been the one constant CPU issue with VSL and it's really frustrating.  Any news or updates would be great.  I have tried all the things people here have mentioned and still no resolution.

    Thanks,

    Seth

    MacPro - Latest version

    128gbRAM, separate 2TB SSD drive solely dedicated for only VSL products.  Logic Pro - latest version.


  • Same problem here. Its strange because I was doing very well with the I-lok version of the libraries until I reinstalled them on the new M1 MacBook Pro. The libraries are now taking a lot more CPU than before and of course it should be the other way around since the computer specs are now higher.

    Hope this gets solved soon. Im working on a project that needs the VSL libraries.

    Saludos,

    Roberto


  • I'm having the same issue. I just installed Synchronized Dimension Strings on iLok and can only play 3 or 4 notes before getting 100% CPU and dropouts.


  • last edited
    last edited

    Hello everybody,

    Sorry to hear that you are still experiencing these issues, after all the fixes that were implemented since spring.

    A few things to check:

    - Correct formatting of your SSDs: ExFat will deliver VERY bad performance!
    - Did the PRELOAD SIZE in your Database Settings change with the switch?

    If that doesn't change thinks: Please send us exemplary projects along with description/reproduction information and the support file you can create with a click in your Vienna Assistant!

    If we can reproduce your findings, we can find out more.

    Best,
    Paul


    Paul Kopf Product Manager VSL
  • Hello. Which SSD type is recommended for Dimension Strings I, Sy'd Historic Winds and your free stuff? Is SATA III SSD good enough or can it slow down performance if for example all sections of DS are used? My CPU supports NVMe with PCIe Gen3 X4.

    BTW, I have CPU spikes too (AMD 5700G) when using DS. The libraries are on HDD now because I just wanted to try them. After reading previous comments though, I'm worried that the problem will remain even after putting them on an SSD.


  • Hi Paul, I am having the same problem of very high CPU usage when using the Synchron Player. Simply playing the instrument itself peaks the instrument.

    I am using the version 1.1.2063 (latest available on my download) of Synchron on Win 10 latest drivers and 16GB Ram on i7 processor. I use an internal SSD 2TB NTFS format. 

    Please help fix.

    BR,
    Shiva