Vienna Symphonic Library Forum
Forum Statistics

178,800 users have contributed to 42,061 threads and 253,916 posts.

In the past 24 hours, we have 2 new thread(s), 6 new post(s) and 80 new user(s).

  • Vienna Synchron Pianos Update

    I have installed the Vienna Synchron Pianos update.

    I am now getting far more crackles than I was before, effectively it was 0. Just on a very rare occasion, but now it is quite constant without other settings being changed. Using the CPU monitor the CPU usage seems to be quite a bit generally higher than it was previously.

    I have a six core 3.2 GHz Mac Mini i7, with 32GB of RAM and a 1TB SSD drive running Catalina.

    Can I go back to the previous version of Vienna Synchron Pianos?

    I am running with 5 microphone positions with the BI and I know this is not a trivial configuration. But it does feel disappointing that a software update can result in a reduction of choice because of the added demands on the system for the same configuration.


  • last edited
    last edited

    Hello KevinMe,

    That is strange (and it's the first report), but of course you can roll back. Simply remove the added Library Update files and you should be fine.

    If you want to roll back with the player software, please find the previous version in our Downloads Archive.

    Best,
    Paul


    Paul Kopf Product Manager VSL
  • Hello Paul,

    Just to inform you that I have also the same issue as Kevin, I have with the last Vienna Synchron Pianos far more crackles than I was before, some random peak.

    My config is pretty good (Windows 10 - I9-9900k with RME Fireface UCX and SSD Drive), sometimes I have a random peak to 100%. I have also tried to decrease my buffer from 48 samples (it was ok before) to 256 samples: it doesn't seem to solve the random peak issue.

    I'm testing with Steinway D Concert Sur to Stereo preset, and Yamaha Concert Sur to Stereo preset, it's exactly the same issue.

    Regards

    Image

    Image


  • Hello,

    For information, I have roll back to version from 1.1.1518 to 1.1.1508 and the issue disappeared (no more random cpu peaks).

    I'm very surprised that there isn't anybody else (except Kevin) with this version issue...

    Regards


  • Hi,

    We had to fix a serious bug in that version, but you should not get worse performance because of that (should in fact be a little better now).
    Have you altered the streaming settings? If so please change the settings back to the default values -> Settings -> Engine:

    - Streaming Threads: 4
    - Loading Threads: 4

    Best, Ben


    Ben@VSL | IT & Product Specialist
  • Just thought I'd add that I also had the crackles and strange cut outs after updating to the latest version 1.1.1518. I noticed that it wasn't that bad or noticeable while playing without the sustain pedal but as soon as I started using the pedal I got immediate cuts in audio and CPU spikes to 100% (normally never goes higher than 40-50% on my i7). 

    I am also using the Steinway D and tested with the presets 'player surround to stereo'. 

    Rolled back to 1.1.1508 and the issues were gone, great that we have the option to go back so that helped.


  • I did not have time to follow up on this until today. I've installed the previous version. With about half an hour of playing the problem appears to be gone.

    Definitely something not right with the latest player update and going back a version resolves the problem for me.

    For added context I'm using Bösendorfer Imperial full.


  • I've had the same problem. Without changing any settings on my computer, the update caused performance problems running the same patches. I switched back to the previous version  (1.1.1508) and all is right with the world again. 

    What was wrong with the previous version that it needed to be updated? 

    God Bless,

    David


    F308, D-274, 280VC, Bösendorfer Imperial, Vienna Imperial
  • May I ask, does this issue only occur once after starting the player, or does it occur over and over again while playing?

    How many voices are approximately used when the peak occurs?

    Thanks,


  • Same issue here. The piano is now unplayable. I have peaks even when playing a major triad!

    I managed to reduced the CPU level to something manageable by settings the streaming and loading thread to 4 and also setting the Preload Size to 16384. I still have peaks to 80% when playing a lot of notes. Also with 2 mics position I set the max voice per mic at 64 instead of the defat 128.


  • last edited
    last edited

    @MS said:

    May I ask, does this issue only occur once after starting the player, or does it occur over and over again while playing?

    How many voices are approximately used when the peak occurs?

    Thanks,

     

    For me personally, the issues occur often over and over again while playing on the latest 1.1.1518 version.

    On every other version I notice that when opening the Synchron Piano software that it spikes to 100% just once which is normal. It also spikes like normal when opening on 1.1.1518 but then continues to spike whilst in use.

    I always use 128 which is the default and have left everything else as default.

    Regards,


  • Bit of an aside, but still performance related.  

    Some larger preload options would be very welcome.  64gb-128gb ram configurations are very accessible these days.  I imagine most of us are happy to focus system resources on improving the live playing experience,  If ram helps at all, let's use as much as possible.


  • Since I am now clicking the don’t update button each time I run the player. That means I am very likely to miss the update that fixes the original problem but does not then create the issue discussed here.

    Could someone from VSL post in this thread when there is a new update. I would greatly appreciate it.

    TIA


  • Hi,

    You can always see what was updated in the changelog:

    https://www.vsl.info/manuals/changelogs/synchron-piano-player#v111518---august-7th-2020

    Best, Ben


    Ben@VSL | IT & Product Specialist
  • Hi Ben,

    Maybe we are facing a side effect of the last patch ?

    I have already tried with default Streaming Threads: 4 / - Loading Threads: 4

    How can we help to troubleshoot this issue ?

    Is-it a known issue ?

     

    Regards


  • Thanks for the offer to help - we'll come back to it as soon as as possible :)


    Ben@VSL | IT & Product Specialist
  • Hi everyone!

    I have a beta build ready that should fix this issue. Please PM me if you have this issue with the last release, I'll send you the download link.

    Many thanks and all Best,
    Ben


    Ben@VSL | IT & Product Specialist
  • Hie Ben,

    I have the same problem whith lot of crackles since I have updated my system : windows 10 20H2, Synchron Pianos v.1518.

    My config  : Windows 10 (20H2), Intel i9 10900K, RME Fireface, RAM 32 GB, all SSD drives.

    I switched back to two previous versions  (1.1.1508 and 1.1.1496), but I have the same problem (screenshot attached at this post). I think the problem is windows and the last update, I don't remember having had the problem with version 1909...

    The piano is actually unplayable...

    Could you send me the download link to the beta build ?

    Thanks !!

    Fred.

    Image


  • Hello Fred,

    After investigation, I have remarked that it could be due to a multi process partially / or no correctly well performed.

    On my case, if I launch multi instance on cubase (split mic) it's far away better ;) !

    Can you check if it improves your issue ?

    You have also raise a good point, maybe a windows update has broken someting on processing !

    Regards


  • [SOLVED !!!]

    Good evening,

    Thank you very much for this trick ... magic !!!

    I explain my approach, which will serve as an aid to those like me who have a problem with the "apparent" processor load of the Synchron Piano, and as a point of support for you, dear developers.

    I confirm the undeniable benefit of opening multiple instances as you suggest. I performed the operation directly with Synchron Piano and not with Cubase. I opened two sessions of Synchon Piano, and I distributed the mics equally between the two sessions. And miracle: I have no more crackles !!

    I noticed, and this confirms an observation made yesterday, that the processor load displayed in Synchron Piano does not correspond to that of the Windows resource monitor: here, the CPU load remains at 1-2% (intel i9-10900K, 32 GB RAM), while it rises to more than 50% in the display of Synchron Piano. In other words, my processor is only used very little. However, when I use two Synchron Piano sessions: - the processor load displayed in the Synchron software is halved, it is distributed between the two sessions. Suddenly, there are no more crackles; - the processor load displayed in the Windows resource monitor has increased: there is a better match between the requested resources displayed and the actual resources.

    I am very happy to be able to play my Steinway piano again, the sound is really excellent. Thanks to the VSL team for their work. And thanks to you, dear, "eagle", for your temporary fix before a next update.

    Fred.