Vienna Symphonic Library Forum
Forum Statistics

174,511 users have contributed to 41,836 threads and 253,012 posts.

In the past 24 hours, we have 2 new thread(s), 9 new post(s) and 79 new user(s).

  • EW Play samples hosted in VEPro get cut off when using bounce in place/offline bounce in LPX

    My PC Slave machine is cutting off the tails of EWHO samples when hosted in VEPro 6 (latest versions of both Play and VEPro). They play back fine in real time, but as soon as I either Bounce in Place or Bounce the Project offline, it cuts each sample. This doesn't happen with Orchestral Tools' Metropolis Ark 1 hosted in VEPro on the PC, nor does it happen with Spitfire's Albion V Tundra (both of which are Kontakt instruments), which makes me think it's something specific to VEPro and Play.

    There is no additional processing within LPX on the host machine. Reverb is turned off in Play on the PC.

    As an additional test, I've just loaded the latest version of Play on the Mac host with a cello sample from Goliath (plugin in Logic without VEPro) and this does not cut off the samples early when offline exporting, but if I run a local VEPro server on the Mac and hook it in that way, I get the same issue as I was getting for instruments hosted on the PC. So it only happens if Play is hosted in VEPro (locally or on a slave machine, on Windows and Mac).

    Is this a known bug, or has something not quite been set up right at my end?

    Play, VEPro & Logic are all running the latest versions.

  • Freezing the track also results in the dropouts

  • So it seems it's an issue with Play in VEPro 6 when it's hosted as a VST (on the PC this is the only option, and on Mac I have a choice of VST or AU).

    Realtime & offline bouncing, bounce in place, freezing - all of these work fine if the Play instance is AU. If I have the exact same setup but with Play loaded in VEPro as a VST plugin, I get the dropouts.

  • Hi, 

    That's definitely a good finding for my colleagues at EastWest to investigate. They have licenses for all versions of VE Pro 6, so this one should be quick to reproduce and fix. 

    Did you concert you AU setup to VST? If yes: how? I think that could be part of the solution. Easy to verify: Does this also happen when you insert PLAY as a new VST plug-in in VE Pro 6? 

    As a quick check, I'd also suggest to test with VE Pro 7, I just send you fully functional demo licenses. 


    Paul Kopf Product Manager VSL
  • last edited
    last edited

    Hi Paul,

    Thanks for getting in touch. I've spent most of today trying to fix this and every test is slowly narrowing it down but still not quite sure what the issue is 😕 

    Since my last post, I also tried running a local server (64 bit) on my Macbook Pro in Logic, and the exact same thing happens. This was with everything up to date, and a clean install of Play 6 and VEPro 6.

    The way I tested it was:

    1. Open VEPro Server 64-bit
    2. Add New Instance
    3. Right click>Insert Plugin>VST>EastWest>Play (Stereo)
    4. Add instrument and set the Midi Channel to 1 in the Instrument Panel Popout within Play 6
    5. Right click>Insert Plugin>AU>EastWest>Play (Stereo)
    6. Add instrument and set the Midi Channel to 2 in the Instrument Panel Popout within Play 6
    7. For this example, I set each VEPro plugin in to Midi Port 1 & Midi Channel All
    8. Open LPX>Add Track>Software Instrument>VEPro (Stereo)
    9. Under the Track panel on the left, select MIDI Channel 1, then hit Cntrl + Return on a Mac to create another track with the next midi channel.
    10. Record some midi chords, duplicate the region onto the 2nd track and shift to the end of Track 1's midi track so there's no overlap and it'll be clear which is which when it's bounced
    11. Right click, bounce in place.

    I'll give VEPro 7 a go now.

  • last edited
    last edited

    @Paul said:

    As a quick check, I'd also suggest to test with VE Pro 7, I just send you fully functional demo licenses. 

    I've just tested it with VEPro 7 and the issue is still there. AU bounces in place fine, VST drops out. And just to be safe, I tested a Kontakt instrument in AU and VST, and both worked fine so it's just Play that's having issues.