Vienna Symphonic Library Forum
Forum Statistics

186,464 users have contributed to 42,460 threads and 255,844 posts.

In the past 24 hours, we have 0 new thread(s), 10 new post(s) and 50 new user(s).

  • VE Pro 6 automatic startup (with .vesp64 file)

    The new Vienna Ensemble Pro is A-MA-ZING!!!

    A good feature to add could be a command-line syntax to autostart the server with a METAFRAME of your choice at startup, something like:

    "C:\Program Files\Vienna Ensemble Pro\ViennaEnsemblePro.exe" - server "C:\Documents and Settings\User\MySetup.mframe"

    Then one could create a link with that command-line and put it in the Startup folder of the Start Menu.

    This feature could help to start a machine automatically loading a metaframe, without any need to interact with that machine at all!!! Just press the "ON" button in the morning and the "OFF" button at night! [;)]

    I have 6 slave machines, so this very very simple feature could speed up enormously the startup process of my entire setup.

    Thanks.


  • This already works, but when adding the .mframe file as argument - you should not add the -server as the first argument.

    Thus: "C:\Program Files\Vienna Ensemble Pro\ViennaEnsemblePro.exe" "C:\Documents and Settings\User\MySetup.mframe"

    is all you need.


  • Yes, you are right.

    I was trying to reply to myself, but the forum seemed to be offline!

    I found out why there was no association between .mframe files and Vienna Ensemble Pro application: in the regedit, the Shell Command always refers to "Vienna Ensemble Pro x64.exe", even if your system is not 64 bit (so that file was not installed by the setup program). Also the Default Icon key has the same problem.

    Correcting those mismatches in the regedit, allowed me to put a simple link to the .mframe file directly into the Startup folder of the Windows Start Menu and everything works like a charm!!!

    Thanks for your reply, anyway...


  • Gemini,

    you are right - it associates with the 64-bit app by default. By using an argument to the excutable however, it will launch the proper version. I was looking on how to improve this for the future, perhaps by naming the mframes .mframe32 / .mframe64, then setting up the file association with the respective executables architecture. If you want to load a.mframe32 in a 64-bit architecture exe, this would then have to be handled by drag-n-dropping it into the app - or by using the File-Open menu.

    Thanks,


  • Thanks to you.

    Actually, my only need now is to automatically load everything (both server and mframe into it) at startup, which I was able to get by tricking the regedit as I said.

    I'm planning to build a new super-server based on 64bit architecture to run everything from there. In that case, your suggestion could be really useful!

    Thanks again for your replies.


  • Nice would be a favorite mount of a specified metaframe in the VEPro server application at startup.

  • last edited
    last edited

    @BloodyJoe said:

    Nice would be a favorite mount of a specified metaframe in the VEPro server application at startup.
     

    Isn't that already implemented? Do you mean being able to do without getting your hands dirty? [;)]

    DG


  • Hi,

    can anybody explain how to do that for dummies?

    How to autostart the 64 bit Server on Windows Vista 64?

    Thank you ;-)


  • From the server dialog (the small one, not the one with the instruments and mixer interfaces), just save a .mframe file, giving it a name of your choice and putting it wherever you want.

    Then create a shortcut to that file (a simple way is to right-click on desktop, choosing "New -> Shortcut" and following the wizard to find the file you want to link to).

    Once you've done, you can put that shortcut in the "Startup" submenu of the "Windows Start Menu" (simply drag the shortcut on the "Windows Start Menu" button, wait for the menu to expand and then drop the shortcut in the "Startup" submenu).


  • Dear Martin. Apologies for asking about so old subject, but I still have this problem on one of my PC slaves under Windows 7 (other PCs are ok). If I double click metaframe file or put it in Windows Start Menu (Startup submenu) then it opens with Vienna Ensemble Pro (64-bit) by default instead of Vienna Ensemble Pro Server (64-bit). Is there any way to make Vienna Ensemble Pro Server (64-bit) to be default application for opening metaframe files?

    If I make a shortcut with -server argument like this "C:\Program Files\Vienna Ensemble Pro\ViennaEnsemblePro.exe" - server "C:\Documents and Settings\User\MySetup.mframe" after double clicking on it I get a message 'Unable to open metaframe file'. Although it opens fine if I start VEP Server first and then open the file. 

    Many thanks in advance for your help!

    Artem

    Windows 7 Ultimate (Service Pack 1) 64bit, i5-2300 CPU 2.8 GHz, RAM 32GB

    VEP 5.4.16181


  • I am also still finding the same error message. "Unable to open metaframe file".

    How did you guys made it correctly? (Windows 7)

    It does NOT work within the autostart.

    Please help us out :) Thanks!


  • last edited
    last edited

    Hi

    Can you guys please help me on how to get VE Pro 6 Server (64bit) opened at computer startup?

    Important: the program itself starts up perfectly!

    But the .vesp64 file doesn't load. It says: "Unable to open server project file." Next problem is that if I put only the file into the autostart folder it will open the VE Pro standalone version and not the Server.

    Thank you for the help 😝👍