Vienna Symphonic Library Forum
Forum Statistics

173,960 users have contributed to 41,805 threads and 252,891 posts.

In the past 24 hours, we have 4 new thread(s), 12 new post(s) and 67 new user(s).

  • VEP 5 & Cubase Pro 8


    Have upgraded to CB 8 on the mac although i've updated VEP5 to the April 2nd version, there's very strange behaviour when running both together. Currently i run VEP 5 on a iMac i7 3ghz with CB 8 on a MP 5,1 12 core 3.46ghz. With a few small synths loaded into VEP5, there's a very noticable delay/latency (1-2 seconds) when swtiching between midi tracks in CB 8. This also conicides with ASIO spikes in CB8. The general concenus is CB 8's new ASIO guard 2 is responsible and in fairness, when it's disabled, all is well. However, given ASIO G2 is supposed to be a more efficent way of handling live audio inputs & VST playablity, having these issues when only playing back 2 midi triggered soft synths on a 12 core machine is bizarre?

    I'm posting this incase anyone else using a similar setup has experienced the same issues and possibly has another explaination and or can offer any further info. I should add, that i use Synergy KM. (A one keyboard and mouse network app to control both mac's over the LAN using a static IP on the MP 5,1). I've also diasbled Hyperthreading on the MP 5,1 using Xcode and have toggled 'Multi-processing' on & off in CB8 but there's no real difference. The only way to completely eradicate the issue is to turn ASIO G2 off. I'm kind off answering my own thread here but, given the power of the MP 5,1, ASIO G2 isn't really needed unless i really max out the cores. Either way, I'd be interested in the opinions of those with similar setups. Lastly, i have read here and on other sites that ASIO G2 has caused issues with audio mixdown exports taking longer then actual real time mixdown's due to ASIO G2 conflict with VEP 5. So is this a VSL or Steinberg issue..........(my bet is that it's a Steinberg coding issue coz my VSL stuff has always worked straight out of the box ;-)



  • It's a known issue. The fix, as you alread figured out, is to turn ASIO Guard off for VEP instances. SB is aware of it, and is apparently looking into improving things.


  • Hi DG,

    Thanks for you reply.

    Intrestlingly, on start up all ASIO G2 is disabled for all VEP instances but yet issue occurs. I'll post on the Steinberg forum as well and see if SB have any new info about this conflict.

    Thanks again,