Vienna Symphonic Library Forum
Forum Statistics

186,187 users have contributed to 42,445 threads and 255,762 posts.

In the past 24 hours, we have 4 new thread(s), 18 new post(s) and 43 new user(s).

  • Newest VEPro 5 update destroyed my Logic project

    Nice and short: using the Multiport Layer environment project that was provided, now with the latest update nothing in VEPro plays. I have 7-8 EastWest PLAY instances loaded in VEPro on a slave MacPro. Soon as I start playing in Logic the connection dies and VEPro freezes and I have to force quit both Logic and VEPro. Sometimes it will play but it'll be the wrong instance that's triggered (!). It's all set up correctly. I experienced this occasionally in the previous build but not 100% of the time like now. Is this a result of loading too many instances into VEPro? I'll have to revert when I get the chance. Is there anyone else with this problem?

  • Not the same here but looks similar. I've buit a small template with 15 East West instruments in one VEP instance using the multiport layer in Logic. I'm missing some notes when I record in live mode or when I hit play. The notes are there but no sound coming out of them.

    Running Logic and VEP in the same computer. No slave here


  • Hello guys ,

    the headline of this thread sounds quite dramatic , therefore it would be great to know  more about your systemspecs ( which MacPro model ;  which version of : OS , Logic, Play, VEPRO, which PLAY library, HD or SSD, etc. ).

    Thanks in advance


  • Here's some more info I have: Logic 9.1.6, PLAY 3.0.32, VEPro 5.0.10309, HD. 8 instances of PLAY in VEPro slave, ~13-15 instruments per instance (some have less though). Sounds play back fine when Logic is stopped (occasionally there are hanging notes), as soon as I hit play or record in Logic, everything in VEPro goes dead and is unresponsive. Only Logic plugins sound. Have to force quit VEPro. I'm not sure what more info I can provide, happy to though if there's anything else I can give.

  • I'd recommend to first of all upgrade to 5.0.10370. Also update Logic to 9.1.7 as it has improved reliability of the Multiport Environment. Does the problem persist?


  • Just a thought :

    Are the VEP instances connected with Logic in "decoupled" mode ?

    If not , try to switch on "decouple" for those VEP Instances in the AU PlugIn Window.

    Especially with PLAY based libraries this is helpful.

    However , in "decoupled" mode you will only be able to save the "name" and direction of the VEP Instances with the

    Logic session , not the PLAY samples inside the particular VEP instances.


  • Do you mean "Unpreserved?" If so, yes, the Preserve button is not highlighted. Just updated to 9.1.7 and 5.0.10370, problem still persists. I can't revert back to 5.0.10068 because now I get an error saying my project was saved with a newer version of VEPro... haha, oh well.

  • Sad to say I just updated too and had my project corrupted (I'm on a PC). All the 3rd party vst's I have on that machine (Kontakt 4, Omnisphere, Trilian) are now not functioning correctly... either VePro does not find them or the data folder addresses for them seem to have been corrupted. I have tried rescanning several times, currently still not working and my project's still down. This coupled with the same leaving of old shortcuts, which all have to be replaced (this happened for the last update too) has made it a tedious, unhappy and frustrating process. Not overly impressed. Upgrades should be way more seamless in this day and age. We are all busy people :( Best wishes, Mike

  • OK I've found what happened - I mistakenly replaced a shortcut with the 32bit version, not 64 bit. My mistake. is there any way theses updates in future can replace shortcuts with the new ones ?! :) thanks, Mike