Vienna Symphonic Library Forum
Forum Statistics

186,246 users have contributed to 42,448 threads and 255,780 posts.

In the past 24 hours, we have 1 new thread(s), 7 new post(s) and 34 new user(s).

  • [SOLVED] VE Pro 5 and Logic - No sound and odd behaviour

    I just bought and installed the upgrade to VE Pro. I'm using an iMac to control my PC slave.

    I've spent hours setting up quite a few tracks according to the instructions but am having trouble getting any sound out.

    • Within Logic, I can only hear sound when playing Midi Channel 1 of each VEP instance.
    • In one particular instance I can't hear any sound at all unless I press play in Logic, then as soon as I press stop, the sound smoothly fades out again!

    I believe I've set it up correctly. For example:

    • I create a Multi Instrument in Logic and connect it to a VEP instance.
    • In the VEP instance I create two instances of Kontakt, each containing 16 instruments assigned to Midi channels 1-16. I change the Midi In and Channel options from Omni to 1-1 and 2-2 (and so on if adding more).
    • In Logic I create two new 16 track multi instruments, load up the VEP Event Plugin in each and assign the Midi channel to each that I assigned in VEP.

    Nothing comes out (apart from channel 1). If I play the keyboard in VEP I can hear all the tracks, but I can't play from my 'real life' Midi keyboard.

    Am I doing something wrong?


  • You are probably lacking the I/O Utility plugin on both the VE Pro and VE Pro Event Input track in Logic. Please check page 35 of the updated manual.


  • Hi Karel.

    I have the I/O plugin on both tracks, set to 1-2 then bypassed.


  • I've tried to reproduce this without success. In the VE Pro instance, make sure to set the first Kontakt channel's MIDI port to 1 and the MIDI channel to Omni, the second Kontakt channel should be set to MIDI port 2 and MIDI channel also to Omni.


  • Hi Karel,

    That's it! I had my Midi Out in VEP set to the Midi Channel rather than Omni, all works properly now.

    Thanks very much for your help.