Vienna Symphonic Library Forum
Forum Statistics

186,358 users have contributed to 42,454 threads and 255,812 posts.

In the past 24 hours, we have 4 new thread(s), 15 new post(s) and 41 new user(s).

  • Vienna ensemble pro 5 not recognizing Midi Off Notes

    HI, I have recently downloaded and installed Vienna Ensemble Pro 5 on my windows 7 64-bit system with Cubase 5 64-bit. When I use an the event input vst plugin in cubase and then I begin fast keyboard playing, the proper midi off notes are not being detected within Vienna Ensemble Pro 5. As a result, my Plugins, which are being hosted in VE 5 (Omnisphere, Machfive, etc) are having infinitely sustained notes that play and never stop. If I play 30 notes, usually one of those notes will hang and continue to play forever. This is some sort of midi off problem that I was not having until I upgraded from Vienna Ensemble 4 to the new version 5. It's getting the "midi on" because its playing the notes in Omnisphere, but not the "midi off" to stop playing them when I let the keys go. Please help me with this issue. Thanks.

  •  May I ask a question. Why are you using the Event input plug? What are you hoping to achieve by using it?


  • Indeed. In Cubase you can use the VST3 version of the VE Pro plugin. The Event Input plugin is just a workaround for AU/VST, which suffer from having only one MIDI input port per plugin.

  • Actually, I'm having similar issues with instruments that worked fine with VEP v4. I'm using the VEP vst2 version as a bit bridge in order to run polykbII (a 32 bit plugin) in my host (studio one pro v2.02 x64). the project uses 4 instances of polykb, and has previously worked without issue, with everything being identical, but for the change to VEP v5. One of the instances of polykb is using an arp patch, and the midi to that arp is getting "hung up", typically by 16th notes i've programmed in the midi. the instrument often fails to see note offs for those short-duration notes. I've set the preferences identically to what they were (16 audio channels out, 8 midi channels, and I've even set the audio in channels all the way down to 2), and nothing I've tried makes any difference. The issue also shows itself with the synthsquad demo periodically. I've loaded a 32 bit instance of zebra2, and it doesn't seem to follow this behavior, though, it's generally not the cpu hog the others tend to be. I've tried the vst3 version of VEP, but it exhibits exactly the same behavior. It's very frustrating, because as I'd mentioned, this worked without a hitch in VEP v4. I'm running an i5 2.3ghz machine wtih 8GB RAM, and CPU via windows task manager averaging somewhere around 30%. I am seeing much higher spikes, which i'd assume could be the trouble...but were they there previously, they've never caused such issues, even on my much slower core2duo vista 32 machine. Any assistance would be greatly appreciated! Thanks! kell

  • I posted this elsewhere, but after reading the symptoms here, I think this thread may be a more appropriate place for my comments. I'm having similar issues when automating with a controller connected to a 32bit VEPro slave running on an MBPro, using the VEPro Event Input Plugin, in a channel in Reaper on the host machine. As the original post mentioned, midi messages don't seem to shut off properly. I had thought that I was in some type of midi 'feedback loop' at the time, but a lack of midi-off messages makes more sense. Once I scrapped the VEPro Event Input plugin, and ran my controller and automation from my host DAW everything went back to normal. I originally moved my controller from my DAW to the slave to free up CPU cycles. Any help from the VSL folks or anyone that's run into a similar issue would be greatly appreciated. :) Best, Jason. Setup: DAW = Reaper on Win Vista 64, Core2Quad, 8gig Ram Slaves = MBPro's on OS X (Lion)