Vienna Symphonic Library Forum
Forum Statistics

179,156 users have contributed to 42,076 threads and 254,014 posts.

In the past 24 hours, we have 2 new thread(s), 13 new post(s) and 56 new user(s).

  • VEP offline bounces not sample-accurate in Logic?

    Hello,

    I've written about this before but because of the useless search feature on this forum I can't find the thread.   If I'm missing something re: search functionality, please let me know  [:S]

    Anyway, no matter what I try, there's something wrong between VE Pro and Logic when it comes to bounces.  Quite often I'll play back a newly-bounced file and something sounds just slightly off.  So I flip the phase on the bounce and play it against the original MIDI regions.  If it's right, it SHOULD completely null (it does when I host instruments directly in Logic, but it doesn't when things are hosted in VE Pro).  I've moved bounced regions both directions by a single sample (consecutively) to see if it's just a sample offset issue, and that doesn't help.

    Tthe only explanation that makes sense is that there are MIDI timing errors happening in the VE Pro engine during rendering, because certain notes jump out more than others when the phase is flipped.  If timing were consistent, the whole file should just sound "phasey" by the amount of sample offset.  As much as I'm loving VE Pro, this concerns me - if it can't properly render audio, the whole thing is a moot point!   Again, I've tried all manner of delay compensation prefs (both Logic & VE Pro), realtime vs. offline bounce, etc.  and this continues to occur.

    Test setup: Mac Pro 8-core (2008) running OSX 10.6.3, Logic 9.1.1, VE Pro 4.0.6150 (64 bit server hosting Kontakt 4.1.1, Vienna Instruments 2.1.5740)


  • Most likely Logic's dynamic latency compensation is the issue here. We're already looking into a workaround for Logic's sub par behavior in this regard. Some users seem to not get any latency compensation at all when bouncing with Logic. A way to avoid it is to set the latency buffers setting of the VE Pro Server Interface plugins to "none" before bouncing. There is no jitter or inaccuracy introduced whatsoever in VE Pro by the way, by design.


  • Thanks Karel.  Good to know you're looking into the Logic workaround.  Not that I have any reason to doubt what you say about Logic's delay compensation, but I do find it odd that I've never had an issue with it whatsoever, in all the years I've used it.   I have seen certain disk-streaming plugins not render offline properly - notably EastWest's Play engine - but anything I host inside Logic generally renders perfectly.

    VE Pro is the first thing I've ever seen that seems to have problems with Logic's latency compensation, but as you say, that might be an "under the hood" issue with Logic itself, especially if no other hosts have this issue.  Hopefully you're able to work with Apple on this so it can be fixed at the source.

    And yes, that was me that reported the workaround of setting VE Pro's plugin buffer to "none" before bouncing.  That does fix the issue.  Of course, it raises another one: since we poor Logic users are hamstrung by the 16-channel AU limit, we have to do this on ALL our instances of the VE Pro plugin, which can get tedious!  It would be nice to have a global option for this setting across all instances - pretty please ;-)

    Thanks,


  • I haven't noticed this issue in regards to Vienna's own instruments but then again i usually work with the buffer at "none" anyway. What I am noticing is terrible timing issues the East West Play plugin. most notable is when there is a stacked structure like a piano chord it actually sounds like a rolling chord! and it seems to be random....will play back correctly about every 4th or 5th time... Any insight here? anyone else see this with the Play plugin? I'm really just using the Pianos right now so thats where its popping up. was getting very excited about the possibility of all this stuff playing nicely together finely but alas... Logic on 10.5 VEP running on a Windows 7 machine. using not the latest VEP but the one directly before that. thanks for any help!

  • And this issue only occurs when hosting Play inside VE Pro?


  • the only time I've noticed it is with Play....as I just started using Play with it since the last update... I haven't had a chance to do any serious testing with it yet. Using the 64 bit server, I have maybe 3 or 4 vienna inst loaded and then just EW pianos gold, using a light patch. a perfectly quantized chord comes up and it literally sounds like a rolling chord so I imagine there has to be like 40-80 ms between notes even though they should be simultaneous. I'll bounce some tracks later to test the exact timing problems. I'm on a gigabit network that I don't share. Thank you for looking into it. Let me know if you need any other info. j

  • I'd be really curious as well to see if this occurs when hosting PLAY directly in Logic...

    Please let us know how it goes!


  • I think I found the culprit.... I had my process buffer set to "large" in logic...changed it a couple of days ago as i was getting tons of errors for some reason. put it back to medium and timing seems to be on again. Does that make sense?

  • Yes, very much so. VE Pro pretty much relies on having the process buffer set to medium.


  • Is anybody still experiencing out of sync bounces in Logic? We've been looking into this but are so far unable to reproduce using v4.1.7384.


  • It seems fine here, Karel.

  • I've been so busy with projects that I haven't been able (or willing!) to do any software updates since I first posted about this issue.  I'll update around end of the year and check to see if the issue still exists.

    It is 100% reproducible & consistent for me though, but the upside is that I know how to work around it... all I have to do is set the VE Pro buffers to "none" when I bounce and everything's fine.  The problem though is that my template has 14 instances of it, so that gets to be a chore...


  • Which version of VE Pro are you currently using? I would seriously recommend updating to 7384. Should you run into any trouble (which is very unlikely), you can just install an older version again without issues.


  • I'm at 4.0.6150.  I've been in the middle of working projects which are heavily dependent on VE Pro and other than this issue it's been rock solid, so I didn't want to risk upsetting the apple cart mid-project ;-)

    I will give 7384 a try ASAP.

    Thanks Karel!

    P.S. I was just in Vienna a few weeks back  - wish I had time to stop by!


  • Hi there - I'm a Logic Pro 9 / VEP user and am having the same problem with latency when bouncing regions in place. Since I have so many instances of VEP running, I was wondering if there was a way to set Logic (and / or) VEP to bypass the buffer settings on bounce. It would be very time consuming to do this every time as I am always bouncing tracks in place. I'm running build 8008. Thank you!

  • Hello,

    There are 2 workarounds for this depending on which version of VEP you have installed.  The easiest is to simply turn off Logic's delay compensation altogether (in Logic's preferences) just before bouncing - then turn it back on afterwards.

    The other is to set your VEP plugin buffer to 'none' - this eliminates the dead space at the beginning of the resulting bounce file.  I think this has been fixed in later versions - not sure off the top of my head.

    Hope this helps!


  • I'm running build 8008. Turning off the buffers before bouncing works. But I would like to know if its possible in VEP (or in a future version perhaps) to give the option for VEP to automatically turn off its buffers only when bouncing in place? The main convenience or me is that I like bounce tracks as I compose and this would be a great time saver. Also since I have so many instances of VEP running in a huge Logic template of over 200 tracks, I would not be able to turn them all off. I would love to run without buffers at all, but doing so makes my cpu spike. As for the other option, Logic's delay compensation altogether / that doesn't seem to make a difference on my system. Thanks! =)

  • Would like to feature request a way for VEP to 'AUTO TURN OFF' buffers ONLY when bouncing midi to audio, then reactivate them after bouncing. Is it possible to do this or only doable manually? Would be a great time saver. cheers!!

  • Hi I wanted to bump this in case anyone has any helpful input. I'm running Logic 9 Pro with three slave PCs running all my samples. I have about 30 instances of VEP running in my Logic template. THE ISSUE: When I bounce audio in place within Logic - the audio renders slightly late to where it should be. I always have to go in and move it back to the correct position every time. The only way to make it bounce perfectly is to disable the VEP buffers within Logic. Then it bounces perfectly in the correct position. But to do this every time is a bit time consuming since I frequently bounce audio in place. So my question is... is there a workaround for this, or is it possible in a future version of VEP to have the option of making the plugin disable buffers (on bounce only)? I would disable them all together but then my CPU spikes in Logic, so thats not an option for me. Thanks!

  • Hi,

    As mentioned above, the easiest workaround for this (instead of turning off the buffers in each VE Pro plugin) is to just turn off Logic's Delay Compensation before doing a bounce in place.  It has the same net result.  I need to check and see if this has been resolved in later versions...