Vienna Symphonic Library Forum
Forum Statistics

174,321 users have contributed to 41,831 threads and 252,976 posts.

In the past 24 hours, we have 2 new thread(s), 15 new post(s) and 68 new user(s).

  • Slow Load up times on external machines Logic and Vienna Ensemble Pro

    I use Logic on my main Mac (8 core) and VE Pro on an external PC (Win 64 xp) and an external Mac (Dual G5 2.7)

    When I connect Logic to VE Pro on my local machine, the connections are instantaneous.

    However, when i connect to my external PC, each instance takes 13 seconds to load. 

    When I connect to my external Mac, each instance takes 24 seconds or so to load.

    Of course, everything is running at 1gHz LAN and I have plenty of ram on each machine (Minimum 16 gigs)

    Since I am loading 12 or so instances of Vienna, it takes MINUTES to load up a simple project. Even if the instances are very sparse (one instrument) it still takes a long time to connect from my master to an external machine.

    Is this normal? Are there certain network settings I should be employing?

    I hope someone can help!!

    Angelo


  • i have the same problem did you fix it?


  • Yes, I did fix it. It seems the problem is with my modem that is from my internet provider. It was the slow link in the chain.

    I disconnected the modem, rebooted everything and everything flies.

    Of course, we need the internet, so i used the 2nd Gigabit ethernet port on my main mac for internet. it is connected directly to the modem.

    no other machine used in VSL is connected to the internet. A bit of a drag, but what can you do.

    All VSL machines connect to my gigabit switch and i can load up a song full of VSL instances in about 15-20 seconds

    I hope this is helpful


  • Thanks for reply , I use the internet wirelessly on my main mac , the others don't connect so I don't think that is it. I don't have a problem with the mac but my pc takes a couple of seconds to respond to Vienna , must be a network issue on my pc . All 3 computers are going through a 1gigswitch. Thanks again


  • Try turning off wireless. Make your whole system self-contained with no outside communication to the internet. Give it a try...


  • Just tried that and sadly that doesnt change it , the PC still takes 2 seconds to connect whereas the mac on the same network is instant when I connect to a Vienna instance.Out of interest I am using a fixed Ip for all the computers staring 169.254.1.x ie x+1,2 and 3 for the 3 computers with the subnet 255.255.255.0 . The pc has a gigabit ethernet card which has a lot of options on it maybe that has something to do with it?


  • I have a similar problem.  DP7 and VEPro5, it takes 12-16 seconds per instance to connect to my external PCs. That means every time I open a template, it usually takes around 5 minutes.  Pretty much makes the product completely useless to me.

    And it's not a problem with my ISP or modem, because I can't even connect to the internet when I'm using VEP - it makes all the instances disappear.  Static IP's don't help either.

    Main computer is a Mac Pro on Snow Leopard, externals are PCs on Windows 7.


  • last edited
    last edited

    @mjbeach said:

    I have a similar problem.  DP7 and VEPro5, it takes 12-16 seconds per instance to connect to my external PCs. 

    Is it to connect and to load the instrument ?

    If you load the VE  manualy on the PC does it takes the same time ?

    Please give all details about your configuration and your settings !! (the best is to put it in your signature)


    MacBook Pro M3 128 GB 8TB - 2 x 48" screen - Most of the VI libs, a few Synch... libs - Quite a few Kontakt libs - CS80 fanatic
  • The external instances are decoupled, so they're already loaded up, it's just the time to connect to them.  That's why I find it so insane that it should take 12 seconds (16 on snow leopard).  I've had this same problem on 3 different rigs, so the configurations aren't all the same.  But here's a sample one.

    Macpro 8 core 3ghz 16GB Mac os X 10.6 (same problem on 10.5)

    DP7.2 (also DP5.13)

    Raydat Audio interface

    ------Connected to----

    Dual Core 3.2ghz 12GB PC running Windows 7, ASUS motherboard

    VEPro Server 64 bit running Kontakt instances and/or Vienna Special Edition

    All the computers are connected via router and 8-port switch, but not connected to outside internet.  The main computer has a second port that's wired to the cable modem, but whenever that one's plugged in, it can't see the Vienna instances (however it has no problem running Midi over Lan - MolCp3, which is what I was trying to upgrade from)

    -

    Thanks for your prompt response - I've been baffled for a while now, and everyone else I know who runs it has no problems.


  • I have seen this happen.

    Some have better results using a gigabit switch between the master and slave machine rather than a direct connection.

    I don't know why.

    If you have one around, give it a try and see if it helps.


  • I had the same problem- up to 5min load up times, running 3 Macs (OS10.6.8 on the Logic host), 13 VEP instances between them, including 2 instances on my Logic host machine.

    I think the thing that fixed it was turning on the VSL external machines FIRST, waiting for them to boot up, and only then booting up the Logic host machine. Now song load up is 36 seconds.

    Other things I did - all connect via a gigabit swtich (they did before too)- all machines have a fixed IP. Made sure all are using Cat 5e cables or faster. Took that Gigabit swtich OFF the internet (the Macs can connect to web via their 2nd ethernet port with different IP). And repaired all permissions on all machines (using Disk Utility). But it wasn't till I booted up in the above sequence that the load-up times returned to speedy.


  • Seems to be a bunch of people experiencing the same problem - this includes myself! It is a huge hindrance to productivity. The question I can't help but ask is WHY Vienna are so silent on this issue?? I've emailed support several times now - I get a few emails in on a ticket, then they give up and tell me it's probably a 3rd party problem or an issue with my network (this is their go-to get out clause I've discovered on anything they can't fix). Please Vienna - listen to your customer base! This is clearly an issue that needs addressing, I implore you.

  • Slow connection times is usually caused by some broken name resolution. First of all, use static IP addresses from one of the three private network ranges: https://en.wikipedia.org/wiki/Private_network, then you can try assigning names for your machines in the hosts / lmhosts files.


  • Mine also take about 5 seconds for each instance I believe. Slave or master, doesn't matter. This used to be much faster on VEP4. I have fixed IP addresses, I tried with and without internet connection etc., nothing matters.


  • Simon, have you ever got this resolved? I changed from VEP4 to VEP5 and my connection times increased massively too. (see my other thread which I just posted).