Vienna Symphonic Library Forum
Forum Statistics

185,137 users have contributed to 42,379 threads and 255,427 posts.

In the past 24 hours, we have 3 new thread(s), 10 new post(s) and 58 new user(s).

  • Connection to VEPro fails

    Hello, is anybody running VEPro on a comparable setup? Master CP: Windows XP (32 Bit) , Cubase SX 2 as the Host Sequencer Slave PC: Windows 7 (64 Bit), VEPro with Epic Orchestra The two Computers are linked by means of a gigaethernet. Master PC: VEPro ist installed, no License-Key inserted. A „New Project“ is started and all file-arrangements done. The projekt contains only one track, which is planned to have access to VEPro on the Slave. When opening the „VST-instruments window“ in Cubase SX2, I see the „Vienna Ensemble Pro“ within the list together with other VSTi. When I select „Vienna Ensemble Pro“ in the instrumentlist, Cubase SX2 crashes. I do not get any window indicating the Slave’s address and the possibility to connect to it. Slave PC: VEPro is installed, License-Key is inserted. VEPro – Server (64) is activated before I open Cubase SX2 on the Master PC. My first steps with VSL- products, what am I doing wrong? Thanks for any help. Jürgen

  • As the above described malfunction could derive from the gigabit-ethernet-connection, I made a test by just installing VEPro on the Master PC. My aim: The use of VEPro as a Plugin only on the Master PC (PC where the sequencer is installed). So I installed VEPro on the Master PC, no „License Key“ beeing plugged in. The installation was performed without any problems. I plugged in the „License-Key“ and started the „Vienna Ensemble Pro Server“. Then I started Cubase SX2, made a „New Project“ and created 1 track in the „Project – Window“. In order to prepare a VSTi for that track, I checked the „VST Instruments Window“ , found „Vienna Ensemble Pro“ and tried to load it. Cubase SX2 crashed as it did in the above described setup with two computers. Is this now the final result? VEPro does not run on Cubase SX2?

  •  First things first. Make sure you are not loading the VST3 version of VE Pro (///)


  • Thank you for the quick answer DG. According to the Cubase SX2 "PlugIn Information" it is VST Version 2.4

  • last edited
    last edited

    One more suggestion. Do you have the possibility to download and test another host such as Reaper (the trial is free)? If that doesn't work either, then you know Cubase is the problem.

    I would also suggest in the interim that you send a crash log to so that they can have a look to see what the cause/culprit is.


  • That's a good proposal. Will try tomorrow. Thank you so far.

  • Hi DG, I downloaded Reaper, installed VEPro once more and it worked. So my conclusion is: As VEPro is working with "Reaper" but not with "Cubase SX2" - both hosts on the same machine - it must be Cubase which is causing the problem. I will consider an upgrade to Cubase 5. Thank you for your assistance.

  • So is the VST3 version known to cause disconnection problems? I suppose then that might also apply for OS X.

    I'm running Cubase on a MacBook Pro with a local VE Pro instance, with another computer running VE Pro on Windows (gigabit ethernet), and both the local and the networked VE Pro Servers seem to lose connection with the VE Pro plugins in Cubase, especially if I save without enabling decouple first. This seems to correlate with how heavy the VE Pro instances are. If it's just a couple of instruments, no problems. But around 10 things start to get shaky.

    I'll try with the VST2 plugin next. Does anyone know whether we actually even get any benefit for using VST3 with VE Pro? I don't know if the VST3 idling functionality is even applicable to basically having an entire host within the plugin (i.e. mostly no idle moments anyway), and I suppose from the user side that's the only reason to be using VST3 right now anyway.

    EDIT: Oh of course one big thing with VST3 is you get multiple MIDI ports into VE Pro. That would be kind of a drag to go without.

  • I have fixed the problem. CubaseSX2 is running on my Master PC Windows XP 32 Bit. VeproServer is running on my Slave PC Win 7 64 Bit Both linked via gigabit ethernet. The use of CubaseSX2 is limited to the use of the VEPro Server (32 Bit). Whenever VEPro Server (64) is activated on the Slave, CubaseSX2 crashes. Hopefully other users with older Cubase versions can participate in the findings. So the problem is solved and I will continue my attempts to understand what is written in the manual.