Vienna Symphonic Library Forum
Forum Statistics

181,740 users have contributed to 42,180 threads and 254,564 posts.

In the past 24 hours, we have 1 new thread(s), 12 new post(s) and 61 new user(s).

  • Sonar 7 - how do I select tracks when using a controller keyboard?

    HI,

    I just switched to Sonar 7 Home Edition. I have set up several MIDI tracks, each activating a channel on GIGASTUDIO 4. Thats fine.

    I then use my midi controller keyboard to play the sounds. Thats fine too!

    However, when it comes to selecting WHICH tracks I want to play (via my controller keyboard) on SONAR 7, it's a nightmare.

    I seem to have no control over which tracks I switch on or off. The mute and solo (on SONAR 7's individual tracks) are only for playing back recordings. I have to keep solo'ing/muting the channels on GIGASTUDIO 4 which is a pain. I like to practice with a certain number of tracks activated at a time, rather than having to hear ALL the instruments or a random selection.

    Does anyone have a solution please?

    [8-)]James.


  • Shouldn't this be posted in the Giga forum?

    DG


  • I don't know about the Gigastudio 4 aspect of your question but regarding Sonar 7, in the Track View, right click on the track that you DON'T want to play and click "MSR" +  "Archive."  That should shut the track down so to speak.  When you need the track reactivated, right click it again, "MSR" and uncheck the "Archive" selection.  If you want to shut down a series of tracks just highlight the tracks in question using control or shift keys then right click MSR + Archive.

    I use Sonar 7 Producer but I think it's the same.  I hope this helps.


  • Thanks for the reply Jason.

    I just tried your suggestion (right click the track, MSR then Archive).

    Unfortunately this has no effect on the tracks. I still get all the tracks sounding. So wierd! I archived all the tracks and all of them sound.

    I never had this problem on Sonar 1.


  • Hmmm... Interesting.  It looks like I'm going to have to do a bit more thinking on this one.

     

    This is very peculiar because AFAIK when you archive a track in Sonar it no longer sends or receives MIDI data.  In fact, archiving tracks is a great way to reduce stress on your CPU. 

     

    I'm wondering if something is going on with Vienna.  I assume you have your VI's hosted in a Vienna Ensemble instance?  By any chance, you don't have the MIDI set to OMNI in each VI GUI do you?

     

    Another question, not that it's any of my business but why are you using both Gigastudio and Sonar to play.  Why not just use one or the other?

     

    You'll have to excuse me because I know you came here looking for answers instead of answering questions but I just find this perplexing as I don't understand why Sonar is behaving this way.